This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: [XCP] Error when trying to import vmware images

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Re: [XCP] Error when trying to import vmware images
From: Jordan Tomkinson <jordan@xxxxxxxxxx>
Date: Wed, 9 Nov 2011 01:51:53 +0800
Delivery-date: Tue, 08 Nov 2011 09:53:17 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=mime-version:sender:in-reply-to:references:date :x-google-sender-auth:message-id:subject:from:to:content-type; bh=Hv073CunYvRqx9UMeZi4Ac8DVAcgD0WLzOtwD21jTIE=; b=CPwMBphrN1mbG/vIcxm7fVF931yB9AI5IzUH2iTAJHCM3MY+JNcaekhWWrcclB7otk Ok6+o3EwpV7ZEHpGajXB0IGqizCipQGvpiG91D77s4SSBPMAXuJpBIoCCBBTlpcpEUMK yNKPDAA5HETgoQ/4e/FeLpYztbWdA/Zgm9OP4=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <CACqCOVnDh9v1bsowZRw8CH5+6+fYqp5KNXh4w8m4TMUYC4KsyA@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <CACqCOVnt6fzEbmi2NO0jK2Eaai9TwDdq=QODHCPWJiXHVd2qtA@xxxxxxxxxxxxxx> <CACqCOVnDh9v1bsowZRw8CH5+6+fYqp5KNXh4w8m4TMUYC4KsyA@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

copying /packages.transfer-vm/xenserver-transfer-vm-6.0.0-50762p.noarch.rpm from the XenServer 6.0 install ISO to my XCP 1.1 server and installing it (rpm -ivh xenserver-transfer-vm-6.0.0-50762p.noarch.rpm) creates the transfer vm needed to do (vmware) imports from XenCenter

I also bumped my xapi version up to 6.0 (see http://wiki.xen.org/xenwiki/XenCenterXCP) but I don't think this was required.

Hope this info helps someone else out there and looking forward to seeing the transfer vm as part of XCP 1.5 ( ?? )


On Tue, Nov 8, 2011 at 8:10 PM, Jordan Tomkinson <jordan@xxxxxxxxxx> wrote:
For anyone interested, I have diagnosed the problem...

It appears as though the "Import VM" feature of XenCenter relies on a hidden "Transfer VM" that exists in XenServer but interestingly not XCP.

I found this guide from Citrix to restore the Transfer VM on a XenServer - http://blogs.citrix.com/2010/12/09/diagnosing-xenserver-appliance-wizard-failures/ - and will attempt to copy the Transfer VM into my XCP server and install it there.

I will keep the list updated on my progress.

It would be nice to know why the Transfer VM was not included with XCP 1.1 and whether it will be in XCP 1.5 ?

On Mon, Nov 7, 2011 at 2:09 PM, Jordan Tomkinson <jordan@xxxxxxxxxx> wrote:
Hi list,

I have recently migrated to XCP from Vmware Server 2 and have run into issues importing the VM's

Following citrix's guide I tried using XenCenter to do the import directly on the vmdk files
this resulted in XenCenter logging this error:

 "Failed to import. ---> System.Exception: Failed to import virtual disk file. ---> System.Xml.XmlException: Root element is missing."

Followed by a stack trace (I can attach full logs if requested)

I get this same error when trying to import exported OVF files from VMware Workstation

The citrix guide also mentions using xe vm-import, this gives me:

[root@xcp ~]# xe vm-import filename=/mnt/vmware/MyVM.vmdk sr-uuid=2c8e28b5-e0b4-2901-9635-1c824f43aeb6
The VM could not be imported.
msg: INTERNAL_ERROR: [ Failure("int_of_string") ]

I have also run "qemu-img convert -f vmdk MyVM.vmdk -O raw xen_compat.img" and tried to "xe vm-import" the img file but was presented with the same error.

What am I doing wrong here?

Xen-users mailing list