This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Starting basic HVM -- where am I going wrong?

On Jul 9, 2011, at 8:04 AM, Sam Mulvey wrote:

On Jul 9, 2011, at 7:17 AM, kcobler@xxxxxxxxxxxxxx wrote:

As long as it is readable.

Here is a copy of a working HVM (Windows 7) that I use.

Note: I first created the disk file (/var/lib/xen/images/win7/disk0.img) with all zeros, so it will appear as an unformatted hard drive to the guest OS. The first time, I ran with boot="d" to boot off the CDROM to load. After the OS was loaded, I xm delete win7, changed boot="c", xm new win7 and then started the vm with xm start win7.

In a follow up, I tried it with a burned CD, and it touched the drive briefly before dying again, so it seems to get pretty far in talking to the drives.


I know it's been a couple weeks since I posted this, but I thought I would point out that after reading some other stuff on this list, and some things online, I switched my development machine to the 4.2-unstable tree, and HVM is working.  

Given that I've found a work-around for what I planned to use HVM for (albeit using a NetBSD development snapshot) I'll be sticking with that on my production system until 4.2 or a 4.1.x with fixes is released.    If there's a developer tracking the list who'd like me to do some poking around to find the source of the issue, I'm willing to help out.

Thank you everyone for your advice, and of course for all the work that goes into Xen.


Xen-users mailing list