This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] XCP 1.1 - having trouble provisioning a CentOS guest over NF

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] XCP 1.1 - having trouble provisioning a CentOS guest over NFS
From: "Joe Linoff" <jlinoff@xxxxxxxxxx>
Date: Fri, 15 Jul 2011 14:18:15 -0700
Delivery-date: Fri, 15 Jul 2011 14:19:50 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcxDNLW0CmA2jdbJTvCqG8dtn8NFQQ==
Thread-topic: XCP 1.1 - having trouble provisioning a CentOS guest over NFS



I am trying to provision a CentOS 5.5 guest using NFS. I followed the recommendations on page 23 of http://www.xen.org/files/XenCloud/guest.pdf but kept getting errors like these:


# Error code: INVALID_SOURCE

# Error parameters: nfs repo nfs:, ,


Here are the commands that I used:




set -u -x




# Create the VM

VM_UUID=$(xe vm-install template='CentOS 5 (64-bit)' new-name-label=$VM_NAME_LABEL)


# Disable VNC so that we can use xl console

# URL: http://wiki.xensource.com/xenwiki/Xen_Cloud_Platform%3A_Access_to_VM_console

# Citation: Todd Deshane

xe vm-param-set uuid=$VM_UUID other-config:disable_pv_vnc=true


# Configuration stuff.

xe vm-param-set uuid=$VM_UUID VCPUs-max=2 VCPUs-at-startup=2

xe vm-memory-limits-set uuid=$VM_UUID static-min=2147483648 static-max=2147483648 dynamic-min=2147483648 dynamic-max=2147483648

xe vm-param-set uuid=$VM_UUID other-config:disks='<provision><disk device="0" size="21474836480" sr="" bootable="true" type="system" /></provision>'


# Set the xenbr0 IP address

NETW_UUID=$(xe network-list bridge=xenbr0 --minimal)

xe vif-create vm-uuid=$VM_UUID network-uuid=$NETW_UUID device=0


# install repository

xe vm-param-set uuid=$VM_UUID other-config:install-repository="nfs:"


# Start the VM -- boot off of the network

xe vm-start uuid=$VM_UUID


# echo some debug information

set +x


echo "VM_UUID        : $VM_UUID"

echo "NETW_UUID      : $NETW_UUID"


How can I debug this? I am able to see this host from other parts of my network.


Note that I also tried different variations of the install-repository syntax.



1.  xe vm-param-set uuid=$VM_UUID other-config:install-repository="nfs://"

2.  xe vm-param-set uuid=$VM_UUID other-config:install-repository="nfs://"

None of them worked.


Thank you,




Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] XCP 1.1 - having trouble provisioning a CentOS guest over NFS, Joe Linoff <=