This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Which clocksource should dom0 be using?

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Which clocksource should dom0 be using?
From: Andy Smith <andy@xxxxxxxxxxxxxx>
Date: Wed, 13 Jul 2011 15:10:48 +0000
Delivery-date: Wed, 13 Jul 2011 08:12:04 -0700
Dkim-signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=bitfolk.com; s=alpha; h=Subject:In-Reply-To:Content-Type:MIME-Version:References:Message-ID:To:From:Date; bh=aEwARL/ZXABD6Ern3hWzoolnPGesUG5IXEBuWhJ42e0=; b=3zNvPaB2ZFO2iAEMWEO7nUmvO8x2Xze+5qgQeA5fKMMKu0Pgzz/XqwwfNXfgMJqQZijxR008XX9Pl99NQ8WuDdY6zInac/hLlSn4pGma0o+yVORlBlAy8Rcx7FGmxkZ+;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110713033338.GT5968@xxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Openpgp: id=BF15490B; url=http://strugglers.net/~andy/pubkey.asc
References: <20110713032858.GS5968@xxxxxxxxxxx> <20110713033338.GT5968@xxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)

On Wed, Jul 13, 2011 at 03:33:38AM +0000, Andy Smith wrote:
> I forgot to add that my Debian lenny domUs are running kernel
> 2.6.26-2-xen-686 i.e. 32-bit Xen kernel. I haven't tried a pvops
> kernel in domU yet. I will give that a go.

Using the Debian lenny -bigmem (pvops) kernel in the domU seems to avoid
these issues, with its default "xen" clocksource.

I accidentally booted it with clocksource=jiffies still set and it
locked up with a stream of "CPU stuck" kernel messages as soon as I
tried to look at /sys/devices/system/clocksource/clocksource0/, but
that is a bug for another day..


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>