This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen 4.1.1 DomU Partition table disappearing

To: Hans de Bruin <jmdebruin@xxxxxxxxx>
Subject: Re: [Xen-users] Xen 4.1.1 DomU Partition table disappearing
From: Liwei <xieliwei@xxxxxxxxx>
Date: Tue, 5 Jul 2011 10:32:49 +0800
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 04 Jul 2011 19:34:38 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=mime-version:from:date:message-id:subject:to:cc:content-type :content-transfer-encoding; bh=5bo7K/MSTq9Ru0UHZ88u0TSu6Rk4IoUquzIzNuOn8CI=; b=J3xN1Vu2BjJVFT6EfOvt7Qrh3ni6xxF+YMxmakdLpZmJtP7deSVwoJYH9nxGSBAz0Y 1YGKo4Bxv92RoDUOIM0Z4jZnTDDFlUSO9xuUiUBn+rPn87XMqrCyPsgbQNpViaTXNzfN naktLF+d+bjAf/tiJ+ZDNcWZivq4F04xz7sR8=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
> Message: 4
> Date: Sun, 03 Jul 2011 23:06:16 +0200
> From: Hans de Bruin <jmdebruin@xxxxxxxxx>
> Subject: [Xen-users] Xen 4.1.1 DomU Partition table disappearing
> To: xen-users@xxxxxxxxxxxxxxxxxxx
> Message-ID: <4E10D9C8.3060204@xxxxxxxxx>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> I have just installed a new xen server: xen 4.1.1, 64bit
> xen/stable-2.6.32.x + USB pass throug patch, Atom D510.
> The first DomU I created is running fine, until I shut it down. At the
> moment the guest disappears from xentop, the partitiontable gets wiped
> out. I have checked this by running  watch 'fdisk -l /dev/vg4/temp' on Dom0

    Don't have a solution here, but I have seen the same problem on
one of my DomUs. Maybe if we compare our setups we'd find the cause.
    1. Does your DomU run OpenSuSE (11.4)?
    2. Is your DomU PV or HVM?
    3. If HVM, are you running PV on HVM drivers?
    4. Are you using LVM for your VM images?
    5. Are you using LVM in your VM?
    6. Have you tried using a separate distribution?
    7. Have you tried creating another DomU to see if it exhibits the
same problem?
    8. Have you tried a different Dom0 kernel/xen?
    Basically I remember this problem came up with one of my
xen/Dom0/DomU combinations, but didn't have the chance to find out the
root cause before moving on to another combination.


Xen-users mailing list