This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] DMIDecode on Xen 4.1.0 not working (has /dev/mem handling ch

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] DMIDecode on Xen 4.1.0 not working (has /dev/mem handling changed from Xen 3.x to 4.1.0?)
From: Anthony Wright <anthony@xxxxxxxxxxxxxxx>
Date: Tue, 31 May 2011 13:47:52 +0100 (BST)
Delivery-date: Tue, 31 May 2011 05:49:18 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <30921844.28.1306845727620.JavaMail.root@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I'm trying to run dmidecode on a linux kernel running as Dom0 to find 
out about the underlying hardware. Unfortunately when I run this under a Xen 
4.1.0 all I get back is an error message saying "No SMBIOS nor DMI entry point 
found. sorry.". If I run the same system, but not under the Xen 4.1.0 
hypervisor, everything works fine, and when I did this under a 3.x Xen 
hypervisor everything worked fine too.

Since dmidecode looks at /dev/mem to find the information, has something 
changed to how /dev/mem is handled? Is there a way I get dmidecode to work?


Anthony Wright.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] DMIDecode on Xen 4.1.0 not working (has /dev/mem handling changed from Xen 3.x to 4.1.0?), Anthony Wright <=