This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Solved: Re: [Xen-users] problems installing xen on RHEL 5.5 from binary

Subject: Solved: Re: [Xen-users] problems installing xen on RHEL 5.5 from binary RPM.
From: Andrew Wangsanata <wangsanata@xxxxxxxxxxxxx>
Date: Sun, 1 May 2011 10:36:16 -0700
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Sun, 01 May 2011 10:38:34 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:sender:date:x-google-sender-auth :message-id:subject:from:cc:content-type; bh=rvmlg5yPvmbmkqIg5Uebb0PXW1WUQe96/AV86ZjqB6E=; b=pGhqPKEMr1Rfa2z3q5KNwGS2k9XlSGcEj3l7WkG8LsK3hNO8E77D4pYhzgkpeJ8NZQ kfKXezDox9FuJ+5fzwp00bt5VL62n3ql/Hkq7KdH3paAbAkCg65pgaec3RfvumiMi09R 86DLg1iPMwH8XmI8i6meWIWX/L6F4ijSd6ltI=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:sender:date:x-google-sender-auth:message-id:subject :from:cc:content-type; b=fjSvuxmJu3v+qRU5kghQvvc8e5Q8qWS+AFo394XwgvupvWM1huN81e8X+XuB7ApkVg HDiyaEGBTyuiqdazPBRjEmIBhklytecxco4Z+gDkF6dxB4cWnlCQmQLsJtW9xTe0VssR ft3JpcoVnsmRAawzPoDZpRfLgCh9EjDvVuZwQ=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thank you Mark and Todd! (mark's reply in a seperate email

I did have the xen kernel installed, but wasn't aware i needed to boot into that kernel manually at GRUB (which totally makes sense).
This part was just missing from the instructions i was following.

now it looks like it is working.

Thanks again.


On Sat, Apr 30, 2011 at 6:15 PM, Todd Deshane <todd.deshane@xxxxxxx> wrote:
On Fri, Apr 29, 2011 at 12:51 PM, Andrew Wangsanata
<wangsanata@xxxxxxxxxxxxx> wrote:
> hi all,
> am having a challenge with installing xen via binary RPM on RHEL 5.5
> sudo yum install -y xen
> install xen no problems.
> but when i do
> sudo /etc/init.d/xend restart
> There is no confirmation anything happened. if i try
> sudo /usr/sbin/xm list
> i get
> ERROR Internal error: Could not obtain handle on privileged command
> interface (2 = No such file or directory)
> Error: Unable to connect to xend: No such file or directory. Is xend
> running?
> Any help appreciated. Thanks in advance

Did you restart and choose the Xen kernel at boot?

To confirm, try:
uname -a

> /andrew
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Todd Deshane

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • Solved: Re: [Xen-users] problems installing xen on RHEL 5.5 from binary RPM., Andrew Wangsanata <=