This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] which port do i use to connect to my XCP 0.5 server?

To: "Vern Burke" <vburke@xxxxxxxx>
Subject: RE: [Xen-users] which port do i use to connect to my XCP 0.5 server?
From: "Joe Linoff" <jlinoff@xxxxxxxxxx>
Date: Wed, 24 Nov 2010 14:58:14 -0800
Cc: xen-users@xxxxxxxxxxxxxxxxxxx, Joe Linoff <jlinoff@xxxxxxxxxx>
Delivery-date: Wed, 24 Nov 2010 14:59:57 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4CED95C4.2090805@xxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <8AD4194C251EC74CB897E261038F447868FB78@xxxxxxxxxxxxxxxxxxx> <4CED95C4.2090805@xxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcuMKW+k0eqifDK5TMWZfvKvf2ktqwAAMLQw
Thread-topic: [Xen-users] which port do i use to connect to my XCP 0.5 server?
Hi Vern:

Thank you for your quick reply. I apologize for not being clear in my
problem statement.

I am able to successfully run xe from the XCP server (no port) but I am
unable to run it from the master on the network. The master is not an
XCP. It is a CentOS 5.5 workstation.

I installed xe on the master and tried to run this:

  % xe help
  Failed to contact a running XenServer management agent.
  Try specifying a server name and port.

I then tried that but was stumped at the port. After hunting through
previous emails I found a reference to port 443 but then I assumed that
since it was a default, xe would figure out so I tried this:

  % xe help -s <IP-address> -pw <password>
  Error: Connection reset by peer (calling read )

At that point I was stumped. I thought that the problem was occurring
because of a bad port. It appears that is not the case. Do you have any
idea what the problem might be?



-----Original Message-----
From: Vern Burke [mailto:vburke@xxxxxxxx] 
Sent: Wednesday, November 24, 2010 2:46 PM
To: Joe Linoff
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] which port do i use to connect to my XCP 0.5

If you're using xe from the XCP host's command line, you don't need a 
port. If you're using xe from a different machine, don't specify the 
port unless you have to change it for some off reason, default works

Vern Burke

SwiftWater Telecom
Xen Cloud Control System

On 11/24/2010 5:35 PM, Joe Linoff wrote:
> Hi Folks:
> I downloaded and installed XCP 0.5 on a server machine on my network.
> would now like to communicate with it using xe but I am told that I
> a port number. What port number should I use?
> I tried looking this up on the xen.org web site:
> http://wiki.xen.org/xenwiki/Command_Line_Interface. It said to look at
> chapter 8 in the Administrators guide but that guide is unavailable:
> http://www.xen.org/products/cloud_support.html. The message says that
> is under construction. Where else can I look?
> Thanks,
> Joe
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list