This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Getting started

To: "John McDermott (U.S. Navy Employee)" <john.mcdermott@xxxxxxxxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Getting started
From: John Perry <j.e.perry-t@xxxxxxx>
Date: Wed, 17 Nov 2010 11:21:27 -0500
Authentication-results: cox.net; auth=pass (PLAIN) smtp.auth=j.e.perry-t@xxxxxxx
Delivery-date: Wed, 17 Nov 2010 08:22:15 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <E8EDF9C6-2D98-4E22-BA7E-65EEDCD08F4E@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4CE34EF2.3050802@xxxxxxx> <EC9AC338-D3C4-4E3D-8B43-F60ACBDD0D43@xxxxxxxxxxxx> <4CE3AC6D.3080109@xxxxxxx> <E8EDF9C6-2D98-4E22-BA7E-65EEDCD08F4E@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20101026 SUSE/3.0.10 Thunderbird/3.0.10
On 11/17/2010 10:51 AM, John McDermott (U.S. Navy Employee) wrote:
> John,
> Looks like you are ready to run virt-manager and try to install a
> guest. Also, you might try playing around with virsh? I can't remember
> if OpenSuSE has virsh.
Thanks much for the help.  I've been down this road several times, but
never with help.  I appreciate your attention.  Since I don't get the
initial xend status, I thought I wasn't succeeding because something was
wrong in xend startup or configuration.  Here's what I get now, just as

tana:~ # virt-manager
(trying to virtualize a fully functional WIndows xp installation on its
own partition, using hvm)
Error: Device 0 (vif) could not be connected.  Could not find bridge,
and none was specified

Then it gives what appear to be instructions for starting "a xend
managed domain".  I try that, using the name given in virt-manager:

tana:~ # xm start windowsxpx64
Error: Domain 'windowsxpx64' does not exist.
tana:~ #

The files windowsxpx64 and windowsxpx64.xml do exist in /etc/xen/vm/. 
As I recall, I tried copying them up to /etc/xen/ once, and it made no

I do not recall having heard of virsh before, so I tried it.  "help"
gives dozens of commands, so it appears I'll have a big project just
learning it, if I have to use it.  Is it substantially different or more
capable than virt-manager?

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>