This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Issue starting VM's

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Issue starting VM's
From: Rus Foster <twattycake@xxxxxxxxx>
Date: Thu, 11 Nov 2010 16:28:12 +0000
Delivery-date: Thu, 11 Nov 2010 08:29:15 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:received:date:message-id :subject:from:to:content-type; bh=4rfn6N/zOSg/DjXchS/UZ9alxBE0NZy1pim0GJ8hajg=; b=JonIjzjOp4yYid1VeL3oeV3RX+fnd8/OUGWG1ueRom2k5HEC0Qko/YoGwr7+RKoN1F 6BiUCIDjKkIcIoATwdFm/rqgd2Ttq9Lc9TojK3rzHd8hUPVbKyy9l1NU8Dk99MliBA7+ 1G8sa8rTKRo644znbTKa/B93b1OHj/7PmdHKw=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=DmDnGljr+SqjgMjvn0839o2wNIOH5AcxKbJ8oHiF2Mnn5gwwSL0pxRi1kQxmYOFSc6 QOXu0CyMod5Aoj2stUWfOV0fiXlVU9kBXJP/d7cM9PrgLG1vTF/8eEX1V1RjVrdSgFT4 jvqxs0vnzCZ64DQ//B/++XB4/XRnF8dQh9bYQ=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
We've hit an issue one one of our nodes where we can't get VM's to
boot. When starting we get something similar to

[root@6 vm3024]# xm create vm3024.cfg
Using config file "./vm3024.cfg".
Error: Device 768 (vbd) could not be connected. Hotplug scripts not working.

Gooling seems to say its a xenstore problem so I've tried the
following to find the phantom domains and remove them

xenstore-ls  /local | grep -A10 vm3024 | grep front | cut -d\" -f2 |
grep ^[0-9] | sort -u | while read line ; do xenstore-rm
/local/domain/0/backend/vbd/$line ; done

The VM is still getting the same error and I'm scratching my head.
Anyone with more knowledge ok of pointing me in the right direction?

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Issue starting VM's, Rus Foster <=