This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] newbie: "Is xend running?"

To: Paula R T Coelho <paulartcoelho@xxxxxxxxx>
Subject: Re: [Xen-users] newbie: "Is xend running?"
From: David Cemin <davidcemin@xxxxxxxxx>
Date: Thu, 4 Nov 2010 17:59:14 -0200
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 04 Nov 2010 13:03:31 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:received:in-reply-to :references:date:message-id:subject:from:to:cc:content-type; bh=OqOGHbwZm9FGtOJwRd2u0ZbPZrjKtH4kgU5/KGxC3sE=; b=WIwPLxRm3QudtfsR8d+jF5KQ4prgrgjJq7+6LavkVb8vV4qDzp/Vuw0hMDaWni6fXJ gnIiFiuZEYlqr2NGfCRnq6l6MUU8o7124xvwQu8Q/TZN+BNJI8wPLZVZuGKvkAqR2GxD pXwgjFb8bKry0fJuW4Ia3D+4nAEobTw60Kub0=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=xu4dDl09TeeImo4xafv0oAfvPXFaOUx77oOCCldqc7Y3NSqiKyiXO4nIlPz6B/nnTH TqU8MZ9V4iYTH7+jgIkR3h7MHMHfdiOAbeRehr9UAIFy+C35LvM2H44XszIx4LWy640y 7ebQOZp+Br8lG9aOvAmBJTIM+9cSBLSM0fWzI=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AANLkTik_73cQvEQDgw69LzE=8b1z_Hg8M+teLZWUMSZC@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTik_73cQvEQDgw69LzE=8b1z_Hg8M+teLZWUMSZC@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I was having the same problem, and I have fixed it by reinstalling dom0 with a 64bits kernel.

2010/11/4 Paula R T Coelho <paulartcoelho@xxxxxxxxx>
hello all,

it's my first time ever with xen (or even virtualization in general).

I installed Xen 3.2 on top of a Debian Lenny kernel 2.6.26-2-686 via
apt-get. Boot options are:

title           Xen 3.2-1-i386 / Debian GNU/Linux, kernel 2.6.26-2-xen-686
root            (hd0,0)
kernel          /xen-3.2-1-i386.gz dom0_mem=512000
module          /vmlinuz-2.6.26-2-xen-686 root=/dev/mapper/athena-root ro console=tty0
module          /initrd.img-2.6.26-2-xen-686

but aparently xend it not up:

# xm list
Error: Unable to connect to xend: No such file or directory. Is xend running?

even though:

# ps -ef | grep xen
root        31     2  0 17:41 ?        00:00:00 [xenwatch]
root        32     2  0 17:41 ?        00:00:00 [xenbus]
root      3320     1  0 17:41 ?        00:00:00 xenstored --pid-file
root      3327     1  0 17:41 ?        00:00:00 xenconsoled
root      3781  3727  0 17:48 pts/0    00:00:00 grep xen

I searched google and I've found many posts with the same error, but
got quite confused I confess, because none of the posts (that I could
find) had the same combination of kernel + xen version, and as such I
didn't feel comfortable to try the proposed solutions, as i hardly
understood them...

would you mind guiding me a bit here?

many thx in advance

Xen-users mailing list

David Cemin
mobile: +55 51 93523097
home:   +55 51 32763785
email: davidcemin@xxxxxxxxx
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>