This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: offload issues (solved)

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Re: offload issues (solved)
From: Pierre-Philipp Braun <pbraun@xxxxxxxxxxxx>
Date: Sat, 16 Oct 2010 19:04:03 +0200
Delivery-date: Sat, 16 Oct 2010 10:08:35 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1882c6ea315332baf6cb35ae2489be62@localhost>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <1882c6ea315332baf6cb35ae2489be62@localhost>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: RoundCube Webmail/0.3.1
On Fri, 15 Oct 2010 10:27:16 +0200, Pierre-Philipp Braun
<pbraun@xxxxxxxxxxxx> wrote:
> # ethtool -K ftp0 rx off
> Cannot set device rx csum settings: Operation not supported

ok I was able to disable offloading within the RHEL5 guest,
#ethtool -K eth0 rx off
ethtool -K eth0 tx off
ethtool -K eth0 sg off
ethtool -K eth0 tso off
ethtool -K eth0 gso off
ethtool -K eth0 gro off
or from the dom0 against the vif,
#ethtool -K ftp0 rx off
ethtool -K ftp0 tx off
ethtool -K ftp0 sg off
ethtool -K ftp0 tso off
ethtool -K ftp0 gso off
ethtool -K ftp0 gro off
disabling rx and a few others prints the Operation not supported error,
but disabling those ones does the trick.


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>