This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Removed GPLPV, can't install Novell's Virtual Machine Driver

To: Xen List <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Removed GPLPV, can't install Novell's Virtual Machine Driver Pack
From: James Pifer <jep@xxxxxxxxxxxxxxxx>
Date: Wed, 15 Sep 2010 13:19:00 -0400
Delivery-date: Wed, 15 Sep 2010 10:18:26 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I've been struggling with this for quite some time. I have some older
VMs that had 0.9.11 GPLPV drivers installed. I've tried removing them
manually and I've tried the uninstall batch file. 

They do "appear" to be removed, but I've never been able to get Novell's
Virtual Machine Driver Pack to install on these VMs. I always get an
error when it tries to install the xenbus:

"Setup was unable to install the Xenbus driver and has terminated the

I've even tried capturing the install with ProcessMonitor but was not
able to determine where it's failing. I really don't want to re-install
these VMs as I have a few of them. 

Any ideas on where the conflict may be? The Driver pack installs fine on
any VM I have that has not had GPLPV first. 


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>