This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] unable to destroy domain

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] unable to destroy domain
From: George Shuklin <george.shuklin@xxxxxxxxx>
Date: Tue, 31 Aug 2010 02:29:02 +0400
Delivery-date: Mon, 30 Aug 2010 15:30:11 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:subject:from:to:content-type :date:message-id:mime-version:x-mailer:content-transfer-encoding; bh=yMh8YAePauuEuDTkM5i1nt/6T6+38Mwev8ZZXIcjJgw=; b=Vy5l5NwZSy9UQyutEMia/rvPnFoUbKGPSS4OWDjlzZM9a1VfHNO4uHWAPy7SqYSk3Z 0vgfqkQsjw4vPlXdrp+nFT7pwjHpEsIEX7oa7dxLlicvpbUdZyUHa450V7eOLtMZQsV4 +ZvJqp0F+F9OpAjO6dwyryPD9Otl30TS12YCo=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=subject:from:to:content-type:date:message-id:mime-version:x-mailer :content-transfer-encoding; b=SCu5Ew+1KnsLu7K4ceiu0FjT3lWNUFXXgxm+sjAWn5VaRxMTgQTliYUY/OxqsHuO/B P4udUoXMg9ipPU2ISX7h6GboN8hL57LJb+JP/YMZr9KR/AAyevI+blri7uHmaLtCXTZL ebdcXHbrIC05T6A11UFgMpJxofPbQ6dUrxSn8=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Found very strange situation... I unable to destroy domain. 

At some point I found host in XCP cloud behave strangely. I decide to
evacuate it (migrate all machines to other hosts in pool). But this
operation failed. I look closely and found PV VM with 200% load (2 CPU
with 100% load each). 

I tried to migrate it (no any result), reboot it by xe capabilities (xe
vm-reboot) - no any effect.

I decide to 'do jobs manually'. I run python, import xen.lowlevel.xc and
tried to destroy domain: 

(0 means success, isn't it?)

But after that no any reactions. Domain was still alive.

I have two questions:

1) What that was?
2) How can I definitively destroy domain without reboot host?


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] unable to destroy domain, George Shuklin <=