This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Re: kernel panic in xcp debian vm

I finally got around to upgrade my systems 10 days ago, and it's been running stable thereafter. Today I tried to bring it down using the "speedtest" test described below, but no problem occurred :)

Looks like the problem is solved in 0.5 vs. 0.1.1. I also had problems with the network from some VMs getting isolated (unreachable from other VMs in the pool), but I've not seen this problem either since upgrading.

Many thanks for your help and good work!


On Wed, Jul 21, 2010 at 10:18 AM, Peter den Hartog <peterdenhartog@xxxxxxxxx> wrote:
First upgrade, that helped me allot with my strange issues with Debian 5. If you can't upgrade this system export your vm's to a new xcp 0.5 and try it again, it worked for me. 

On Tue, Jul 20, 2010 at 10:39 PM, Trygve Sanne Hardersen <trygve@xxxxxxxxxxxxx> wrote:
I have not been able to upgrade my systems to XCP 0.5 yet, but I have some additional information that might help someone get to the cause of this error.

My setup is quite simple. I have one Debian Lenny VM acting as a firewall/router (FW) between the WAN and the LAN - traffic from the LAN VMs to the ISP passes through this machine. I'm using Corosync/Pacemaker to provide HA - it switches the global IP to an identical FW VM on a different physical XCP host in case of failure. This kicks in perfectly when the kernel panic occurs.

It seems to me like the error only occurs when the system has been running for a while. On a Windows VM on the LAN I go to www.speedtest.net and perform a bandwidth test. This causes the FW to panic before the first test can finish, but when I restart the FW and do more tests, the panic no longer happens. During normal operation, which involves very little traffic it must be said, I've never seen the error. 

I can't find the call trace for the kernel panic in the VM logs, and the free online OCR tools seem to translate my screenshot wrongly. So I'm providing the call trace as text here:

xennet_poll+0x94d/0x9ef [xen_netfront]
Code: 00 00 00 00 c7 43 04 00 00 00 00 89 10 89 42 04 8b 44 24 04 89 43 14 0f b6 54 24 0c 89 14 24 89 d6 83 bc 97 c4 08 00 00 00 74 04 <0f> 0b eb fe 89 9c 97 c4 08 00 00 8d 87 c4 0c 00 00 e8 03 22 9f
xennet_alloc_rx_buffers+0x176/0x26f [xen_netfront] SS:ESP 0069:c0393e34
Kernel panic - not syncing: Fatal exception in interrupt

Any help is much appreciated.



On Thu, Jul 15, 2010 at 9:01 AM, Trygve Sanne Hardersen <trygve@xxxxxxxxxxxxx> wrote:
I did some more testing today with a fully patched Debian Lenny VM, but unfortunately I got the same error after a short time.

I'm planning an upgrade to XCP 0.5 soon, does anybody know if that could help?



On Mon, Jul 5, 2010 at 7:25 PM, Trygve Sanne Hardersen <trygve@xxxxxxxxxxxxx> wrote:

I'm running XCP 0.1.1 and have a virtual debian-lenny machine configured as a router/firewall using iptables. I've had the same kernel panic twice now during testing of the bandwidth from a machine behind the router.

Attached is the screen dump from XVP Viewer. Any idea what is wrong? I'm no kernel expert but it seems to me like the crash happens somewhere in the Xen code.

I've now performed a dist-upgrade on the virtual machine and hopefully that will help. Will let you know if it happens again.



HypoBytes Ltd.
Trygve Sanne Hardersen
Akersveien 24F
0177 Oslo

+47 40 55 30 25

Xen-users mailing list

Groet // Kind regards,
Peter den Hartog
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • Re: [Xen-users] Re: kernel panic in xcp debian vm, Trygve Sanne Hardersen <=