This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Question: Solaris 10 10/09 HVM on 64-bit Centos 5.4 DOM0

To: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Question: Solaris 10 10/09 HVM on 64-bit Centos 5.4 DOM0
From: Johnson Earls <jearls@xxxxxxxxxxxxx>
Date: Wed, 18 Aug 2010 16:03:30 -0700
Accept-language: en-US
Acceptlanguage: en-US
Delivery-date: Mon, 23 Aug 2010 07:02:48 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: Acs/KZMTle4ImWazQJevVnOok8xHgg==
Thread-topic: Question: Solaris 10 10/09 HVM on 64-bit Centos 5.4 DOM0

    I hope I'm not asking a FAQ, but I've searched google and this list and 
haven't manage to find an answer to this on my own.

    I'm running Centos 5.4 64-bit on Intel Core-2 Duo CPUs.  I'm trying to 
install Solaris 10 10/09 as an HVM guest on this system.  I have the Solaris 10 
10/09 x86 ISO image that I am booting from; I can see the GRUB menu, but when 
it tries to boot to the OS, I stop getting any console output.  I've tried the 
standard [vnc] console, and I've tried using the xen serial 0 console and 
telling Solaris to boot using ttya or ttyb; nothing seems to work.

    The Xen version I'm running is:

xen.x86_64                                 3.0.3-105.el5_5.5           installed

    The HVM configuration is:

name = "test1"
uuid = "01c2dc0e-dd8c-6ef2-d116-4e02f2a534d9"
maxmem = 1500
memory = 512
vcpus = 1
builder = "hvm"
kernel = "/usr/lib/xen/boot/hvmloader"
boot = "d"
pae = 1
acpi = 1
apic = 1
localtime = 1
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
device_model = "/usr/lib64/xen/bin/qemu-dm"
usb = 1
usbdevice = "tablet"
sdl = 0
vnc = 1
vncunused = 1
keymap = "en-us"
disk = [ "file:/export/test1.img,hda,w", 
"file:/root/sol-10-u8-ga-x86-dvd.iso,hdc:cdrom,r" ]
vif = [ "mac=00:16:36:4d:3e:2d,bridge=virbr0,script=vif-bridge,vifname=vif20.0" 
parallel = "none"
serial = "pty"

    Any help, tips, or even being beaten over the head with "you're stupid, 
just do this" messages would be appreciated :)

Thanks in advance!
- Johnson

Xen-users mailing list