This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Xen 4.0 and xen-sources-2.6.34

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Xen 4.0 and xen-sources-2.6.34
From: Mike Fröhner <mike.froehner@xxxxxxxxx>
Date: Wed, 11 Aug 2010 13:19:51 +0200
Cc: systemadministration <systemadministration@xxxxxxxxx>
Delivery-date: Wed, 11 Aug 2010 05:16:22 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Reply-to: mike.froehner@xxxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20100713 Lightning/1.0b1 Thunderbird/3.0.6
Hello Guys,

i am trying to upgrade my server from xen-3.4.2 and xen-sources-2.6.31-r11 on a gentoo-linux to xen-4.0.0 and xen-sources-2.6.34

But first of all I have an important question:

What doesn't xen accept my kernel as Xen Guestkernel with configured CONFIG_XEN_UNPRIVILEGED_GUEST=y. I unterstood that just the domain0 is the privileged guest and the other domains (guests) are unprivileged guests. Would be nice if anybody could explain my Problem

Okay back to upgrade problem. I tried many different things.

First I installed via emerge the new xen-sources and took the old .config from 2.6.31-r11 and made oldconfig. While compiling the new kernel for domain0 I installed xen-4.0.0. Everythings went fine, reboot was ok (no errors, no warning, no kernel panic). After rebooting i tried to start up an old guest machine running a 2.6.31-r11 kernel. This did not work.

Ok, I thought I need to compile a new guest kernel. I copied the old guest .config from 2.6.31-r11 and to new directory (i am using for each kernel another outputdirectory for compiling). I compiled.

So now Host and Guest got both 2.6.34-kernel and host was running xen-4.0.0. I thought a reboot wouldn't be wasted time, I did.

Now i tried again to start my guest. And at this point i do have the problem. I got 2 different boot failures. First is that there kernel could find my guest root partition (VFS ERROR). And the second is obviously no real error. I try to start via xm create -c [config-file] and it start and after some miliseconds it stops and goes out of the console. Just this a warning: (read it at the end of my mail)

Does anybody have experience this gentoo and xen with the new kernel?

I am looking forward to an answer.

Kind Regards,
Mike Fröhner


[    0.189872] ------------[ cut here ]------------
[ 0.189872] WARNING: at /usr/src/linux-2.6.34-xen/fs/proc/generic.c:825 remove_proc_entry+0xe9/0x25b()
[    0.189872] name 'fan'
[    0.189872] Pid: 1, comm: swapper Not tainted 2.6.34-xen #3
[    0.189872] Call Trace:
[    0.189872]  [<ffffffff80207219>] ? remove_proc_entry+0xe9/0x25b
[    0.189872]  [<ffffffff8012c3fa>] warn_slowpath_common+0x72/0x9f
[    0.189872]  [<ffffffff8012c49c>] warn_slowpath_fmt+0x64/0x66
[    0.189872]  [<ffffffff801b4db0>] ? virt_to_head_page+0x15/0x2f
[    0.189872]  [<ffffffff8020701f>] ? __xlate_proc_name+0x3d/0xbf
[    0.189872]  [<ffffffff808e0786>] ? acpi_fan_init+0x0/0x32
[    0.189872]  [<ffffffff80207219>] remove_proc_entry+0xe9/0x25b
[    0.189872]  [<ffffffff808e0730>] ? acpi_button_init+0x0/0x56
[    0.189872]  [<ffffffff808e0786>] ? acpi_fan_init+0x0/0x32
[    0.189872]  [<ffffffff808e07af>] acpi_fan_init+0x29/0x32
[    0.189872]  [<ffffffff80102060>] do_one_initcall+0x5a/0x16f
[    0.189872]  [<ffffffff808c35e6>] kernel_init+0x152/0x1dc
[    0.189872]  [<ffffffff80104ce4>] kernel_thread_helper+0x4/0x10
[    0.189872]  [<ffffffff808c3494>] ? kernel_init+0x0/0x1dc
[    0.189872]  [<ffffffff80104ce0>] ? kernel_thread_helper+0x0/0x10
[    0.189872] ---[ end trace 101cb71362e080d1 ]---

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Xen 4.0 and xen-sources-2.6.34, Mike Fröhner <=