This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] openSuSE kernel-xen bug (netback deadlock issue)

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] openSuSE kernel-xen bug (netback deadlock issue)
From: Mark Pryor <tlviewer@xxxxxxxxx>
Date: Tue, 3 Aug 2010 14:28:40 -0700 (PDT)
Delivery-date: Tue, 03 Aug 2010 14:31:02 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s1024; t=1280870921; bh=P9NLJRVO9aFT33c63h4Wh3oF5FGl6cYUDEKSNWcTO8s=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type; b=S48f3G4ZTFMgVHpvbBZt+GA4kzatFDeunz/m8hJtyBYiKSpRZB3rQV82UkoUdCtQ2WjUCIDG1PIvsAnud/hWBikKGlshob0gq/T1HtmK7yWX0mgq7b94Vrl3AU6GmPlTAzSOnqkvL7hxDU9d6RpvAzBoHlAAjNCsZx2yTAFvVD4=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type; b=pGj4DFj1bprchyUCZ6ASfvrS+1qULiIf2w0Z6M8PC2y7+FbHWKvE5nf153zg35NkvmXtrRnpi9E7ZC4gTXkXyJ1F4TSTXZYYUtbR3+GPKFOE7QFc7ZcQRYrxabHSfzGD/biCGnKLS9TaHa0MAe5ZdwhHtgSRfPlnzZI5JwM0dts=;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

As mentioned by Boris here

there is a serious bug in kernel-xen 2.6.34-12, which is the default dom0 
kernel for the latest 11.3 release.

Good news is the bugzilla.novell.com has covered it and a fix is available in 
KOTD (also noted by Boris).


I wasted considerable time struggling with my 11.3 dom0 install, until 
realizing that I was up against the same bug. The KOTD solved it, but the 
factory kernel (2.6.34-14.x) didn't. Don't waste your time importing the 
factory repo and installing kernel-xen from there.

I ran my 11.3 dom0 for weeks before a path typo in disk=[] triggered this bug. 
Everything worked great: old VM's and new PV installs too. Only a vbd path 
error brought the deadlock. When a vbd error stopped 'xm create', the vifx.0 
was not released and was stranded after the domU closed.



Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] openSuSE kernel-xen bug (netback deadlock issue), Mark Pryor <=