This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Problems with pci passthrough with Xen 3.4.2

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Problems with pci passthrough with Xen 3.4.2
From: francisco javier funes nieto <esencia@xxxxxxxxx>
Date: Wed, 9 Dec 2009 18:13:14 +0100
Delivery-date: Wed, 09 Dec 2009 09:16:04 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:date:message-id:subject :from:to:content-type:content-transfer-encoding; bh=xPev7jWTCMWHg7ApALZI4gliC24JdhhWW7Oclt3ABZ4=; b=YoIsE3gguCNnN9WW31IYQMUlj7n+A2+s6bUD3/UCK4wLg2dQioKrr+gpdxWtrtwrJ6 9wJq0bdbiIEiDVnlPyLH7tbHieeKFMG05J9Pp3zxRiqoi5cO5JNg0y+nR2T+mGBrcSOR 5BsoKjXQvSEiF9p/6n5/gMocmTMzU1oyowvvQ=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type :content-transfer-encoding; b=j+EgNCpDhnnDbYbm3MFWLbSLxAzaPj8u/IwncLCo9g8NDBIQ9nkI3Opas5QwWDDUsf 9REtFC45qktiyzx2guKEJHWF4nBzVImlxcOFjGTBEtAjuyxD+1PG8FvN/O9QCSpYMMmq IU4OqUGBCJLhGKJSQ8a+5tJTqBnEefNyC5Des=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi all!.

First of all sorry about my English it's not very fluid.

I have a small server based upon Supermicro X7DBN (Chipset Intel®
5000P) motherboard and Intel Xeon E5320 (1,83Ghz) with 4Gb of FB-DIMM

The OS is Debian Lenny in dom0 (2.6.26-2-xen-amd64) and Debian Lenny
in domU (2.6.26-2-xen-amd64).

Xen is 3.4.2 compiled from sources.

The problem comes when I need to passthrough the second gigabit
ethernet interface to a domU. I've got an "pci: improper device
assignment specified:" error.

Here is the menu.lst:

module          /boot/vmlinuz-2.6.26-2-xen-amd64 root=/dev/sda1 ro
console=tty0 pci=nomsi pciback.hide=(04:00.1)

Here is the lspci output:

main:~# lspci |grep Ethernet

04:00.0 Ethernet controller: Intel Corporation 80003ES2LAN Gigabit
Ethernet Controller (Copper) (rev 01)
04:00.1 Ethernet controller: Intel Corporation 80003ES2LAN Gigabit
Ethernet Controller (Copper) (rev 01)

Here's the xm info:

main:~# xm info
host                   : main.chauchinasincables.es
release                : 2.6.26-2-xen-amd64
version                : #1 SMP Thu Nov 5 04:27:12 UTC 2009
machine                : x86_64
nr_cpus                : 4
nr_nodes               : 1
cores_per_socket       : 4
threads_per_core       : 1
cpu_mhz                : 1866
hw_caps                :
virt_caps              : hvm
total_memory           : 4094
free_memory            : 128
node_to_cpu            : node0:0-3
node_to_memory         : node0:128
xen_major              : 3
xen_minor              : 4
xen_extra              : .2
xen_caps               : xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32
hvm-3.0-x86_32p hvm-3.0-x86_64
xen_scheduler          : credit
xen_pagesize           : 4096
platform_params        : virt_start=0xffff800000000000
xen_changeset          : unavailable
cc_compiler            : gcc version 4.3.2 (Debian 4.3.2-1.1)
cc_compile_by          : root
cc_compile_domain      : chauchinasincables.es
cc_compile_date        : Tue Dec  8 20:57:01 CET 2009
xend_config_format     : 4

Here's the domU config file with pci device:

pci         = ['04:00.1']

And here's the error when I try to create the VM:

main:~# xm create /etc/xen/proxy.chauchinasincables.es.cfg
Using config file "/etc/xen/proxy.chauchinasincables.es.cfg".
Error: pci: improper device assignment specified: pci: 0000:04:00.0
must be co-assigned to the same guest with 0000:04:00.1, but it is not
owned by pciback.

With Xen from Debian Repository (3.2-1) it works very well!
But not the same result with compiled from source Xen (3.4.2).

Can anyone show me how to configure this?

I've tried xm pci-attach but pci-list-assignable-devices shows nothing
and pciback module show that the device is seized from dom0.

I'm really lost...

thanks in advance.


Francisco Javier Funes Nieto [esencia@xxxxxxxxx]
Servicios Informáticos para PYMES.
Cl. Cruz 2, 1º Oficina 7
Tlf: 958.536759 / 661134556
Fax: 958.521354
GRANADA - 18002

Xen-users mailing list