This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] Xen fails with garbled boot screen - incompatible hardwa

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] Xen fails with garbled boot screen - incompatible hardware?
From: "Ben Bradley" <ben.bradley@xxxxxxxxxxxxxxxx>
Date: Thu, 3 Dec 2009 11:46:39 -0000
Delivery-date: Thu, 03 Dec 2009 03:47:21 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <76D9B0388818194A99518022CA81706F0119FFDC@xxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcptzbXQixtsqLJSRa+WJGqkM2ap8wGQAtaw
Thread-topic: [Xen-users] Xen fails with garbled boot screen - incompatible hardware?
Hi everyone

Anyone got any ideas on what might be happening here?
Anything else I should try to debug this?

Cheers, Ben

-----Original Message-----
From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
[mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Ben Bradley
Sent: 25 November 2009 12:49
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Xen fails with garbled boot screen -

Hi everyone

Ok this is really strange. I've been messing around with Xen for the
past few weeks on a 32bit test machine and CentOS 5.4 and it's been
working fine.
At the weekend I went into the office to install Xen on our server but I
had a major problem.

The server is a home-build with a Tyan s5211 motherboard with an Intel
i3210w chipset CentOS 5.4 64bit installed and rebooted several times
without any issues. This server also has a 3Ware 9690SA-8i RAID card in
it as well which has never caused any problems. Ubuntu 8.04 has been
running on this machine for the last 18 months or so without any

I did a fresh install of CentOS 5.4 64bit then installed Xen using the
basic "yum install kernel-xen xen" method and made the changes to grub
to try booting Xen.

The boot into Xen started ok but just after the section "waiting for
driver initialization" the screen became garbled with all the boot
messages and coloured blocks scrolling up the screen at mega-speed so I
had no chance of reading the output on the screen.
After a quick google I found someone running Debian/Xen on the same
board with the same problem...

I tried installed the latest Xen (3.4.1) from the gitco.de repos and the
same thing happened.

This leads me to think it might be a motherboard incompatibility... I
really hope not as I'd love to get Xen working on this machine!

I connected to the serial console port and watched what was happening
and changed loglvl=all
Here's the serial console output:
I tried checking for when in the console output that the garbled screen
started and it was either the "kjournald starting" line or after that.
Anything above that line, the monitor output was fine.

Here's my menu.lst for reference
I changed default=0, added those console options to get the serial
connection going and added loglvl=all to get more info when I started to
have problems.

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/sda3
#          initrd /initrd-version.img
title CentOS (2.6.18-164.6.1.el5xen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-164.6.1.el5 com1=115200,8n1 sync_console
        module /vmlinuz-2.6.18-164.6.1.el5xen ro root=LABEL=/
console=ttyS0 console=tty
        module /initrd-2.6.18-164.6.1.el5xen.img
title CentOS (2.6.18-164.6.1.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-164.6.1.el5 ro root=LABEL=/
        initrd /initrd-2.6.18-164.6.1.el5.img
title CentOS (2.6.18-164.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-164.el5 ro root=LABEL=/
        initrd /initrd-2.6.18-164.el5.img

Anyone got any ideas of what could be going on here?
Or anything else to try and get Xen to boot?
I'm happy to provide any further debug info I can, but I'm new to Xen so
not sure where to dig for further info

I'd really like to get Xen up and running on this machine.

Thanks, B

Xen-users mailing list

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>