This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] 3.4-testing : Kernel panic on bootup (mount: couldnotfin

To: "Fajar A. Nugraha" <fajar@xxxxxxxxx>
Subject: RE: [Xen-users] 3.4-testing : Kernel panic on bootup (mount: couldnotfind filesystem /dev/root/)
From: "Madhu Venugopal (vmadhu)" <vmadhu@xxxxxxxxx>
Date: Fri, 28 Aug 2009 00:22:48 -0700
Authentication-results: sj-dkim-2; header.From=vmadhu@xxxxxxxxx; dkim=pass ( sig from cisco.com/sjdkim2002 verified; );
Cc: Xen User-List <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Fri, 28 Aug 2009 00:23:39 -0700
Dkim-signature: v=1; a=rsa-sha256; q=dns/txt; l=3175; t=1251444171; x=1252308171; c=relaxed/simple; s=sjdkim2002; h=Content-Type:From:Subject:Content-Transfer-Encoding:MIME-Version; d=cisco.com; i=vmadhu@xxxxxxxxx; z=From:=20=22Madhu=20Venugopal=20(vmadhu)=22=20<vmadhu@cisco .com> |Subject:=20RE=3A=20[Xen-users]=203.4-testing=20=3A=20Kerne l=20panic=20on=20bootup=20(mount=3A=20couldnotfind=20filesys tem=20/dev/root/) |Sender:=20; bh=z5tciBqjPgu56DCkG/lrtSHm/PlBU5ZhG8Ut3s2CuSI=; b=dReUpczXqvDcp2JUaXX4l1nNZqT8SLGrvD23cx0BI69dILDpmCVpKgt/41 NqXOJ2ba2Iv/6P5GNkzlbyWJOeTnKInbrKmFlFP6LPdNPnJsD2vlhfQ8PPT1 u3/Vxb9HsX;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <7207d96f0908280001m13d7b041i339ad0d97d3906ed@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <66EB4A5E3F739E40BFC2567243002B830787F065@xxxxxxxxxxxxxxxxxxxxxxxxxx> <66EB4A5E3F739E40BFC2567243002B83078F3463@xxxxxxxxxxxxxxxxxxxxxxxxxx> <00f001ca264e$a3e13370$fcdf0a0a@xxxxxxxxxxxxxxx> <66EB4A5E3F739E40BFC2567243002B83078F36EA@xxxxxxxxxxxxxxxxxxxxxxxxxx> <7207d96f0908270552x6aa640c7r49662c9a5dfa06be@xxxxxxxxxxxxxx> <66EB4A5E3F739E40BFC2567243002B83078F3DD9@xxxxxxxxxxxxxxxxxxxxxxxxxx> <7207d96f0908280001m13d7b041i339ad0d97d3906ed@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AconrVmgJsbfQOnfRJSk6Fn2jEoZvAAAetcg
Thread-topic: [Xen-users] 3.4-testing : Kernel panic on bootup (mount: couldnotfind filesystem /dev/root/)
> >
> > Okay. How would I find what modules are missing ?
> > I don't see any such error in the bootup logs. Any other suggestions
> ?
> Start with the boot log. It usually shows you what block devices are
> detected, etc.
> The basic ones for domU (2.6.18 kernel) are xenblk (domU block device)
> and ext3 (or whatever file system you use). For dom0 kernel, it's
> easier to see the output of "lsmod" from your working installation.

I tried lsmod on the Base CentOS 5.3 installation and saw these :

dm_raid45              66509  0 
dm_message              6977  1 dm_raid45
dm_region_hash         15681  1 dm_raid45
dm_log                 14529  3 dm_mirror,dm_raid45,dm_region_hash
dm_mod                 62201  4 dm_mirror,dm_multipath,dm_raid45,dm_log
dm_mem_cache            9537  1 dm_raid45
ata_piix               23621  0 
libata                156933  1 ata_piix
cciss                  63813  3 
sd_mod                 25153  0 
scsi_mod              141589  6 scsi_dh,sr_mod,sg,libata,cciss,sd_mod
ext3                  124233  1 
jbd                    56937  1 ext3

I could not see the dm_raid45, dm_region_hash in the
Directory. Hence I copied these from /lib/modules/2.6.18-128.el5PAE/.

After this I ran mkinitrd again. I still see the kernel panic, Also I
see a few error
message during bootup : "dm-raid45: disagrees about version of

Looks like I cant just copy over the modules...

I will try your other suggestions...


> >
> >>
> >> - Install RHEL's Xen. This should be pretty straightforward, you'd
> end
> >> up with Xen 3.1+ and a working grub.conf stanza for Xen with RHEL's
> >> kernel-xen
> >> - Install Xen package from gitco (http://www.gitco.de/repo/). You
> can
> >> get Xen 3.4.1 (currently in testing) but still using RHEL's kernel-
> xen
> >> - If that works, you can simply compile another xen kernel as you
> >> like, using either 2.6.18 or later pv_ops kernel. If using 2.6.18,
> you
> >> can use RHEL's kernel-xen config as a base.
> >
> > I didn't want to take this approach. We have standardized on the
> > approach
> > to take with the existing XEN installations and kernel to use.
> Standard is fine, if it works. What I'm saying is if you want to find
> out what's wrong (is it Xen userland? kernel version? kernel config?)
> the steps above can help.
> > It is
> > confusing
> > that am the only one seeing this issue while it works just fine on
> other
> > Machines. This makes it clear that it is machine specific and am
> missing
> > Some drivers for them. But am clueless on what is that am missing
> > how
> > To include them in initrd. Any suggestions ?
> For starters, copy RHEL's kernel-xen config to the kernel from xen.org
> (like
> 3.4.0.tar.gz).
> That should provide similar set of modules.
> Then try running mkinitrd WITHOUT --allow-missing. It should show you
> what modules it thinks you should have but currently missing.
> --
> Fajar

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>