This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Creating a Fedora 11 DomU

To: Boris Derzhavets <bderzhavets@xxxxxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Creating a Fedora 11 DomU
From: Ian Murray <murrayie@xxxxxxxxxxx>
Date: Tue, 25 Aug 2009 22:51:08 +0000 (GMT)
Delivery-date: Tue, 25 Aug 2009 15:51:51 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.co.uk; s=s1024; t=1251240668; bh=c38/7A+Znpqh3rHCOlM8zEek7D8IqXbGmVL6rIqccBE=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=yMtzZkv9nveXTff9ANc2zs2DpkabPwN+n6nNTgWBt7h9l+95UlynqESCSHHG6G6tvkDNSYhZ3GrSXPqq56y8cXqcijBYs2yQlrNk/0wTEotxhst9jEEKv0QqgOPsFsO6TroETPqO6SxFwNDieLv3DS44MlA7mdyA1aM947A48co=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.co.uk; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=m2u3zIJ1iDNZqFfEp+ze++hMIr5KbHQj8Xko9m9kE2ODthtGp7URwgYGcMeZ9Qxnp/GW0g+L2bULwVw+fYUMZk/Xd6IyUEgmvBSRUjg27fD2E60PHcddx2vz0K8m0fx2NxwLKJ6isLACBrgn1gqFUVTT4hSEZQW8V96+BNa2UPs=;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I am afraid this didn't help. I used a mirror on another DomU, as I don't have 
a webserver running on Dom0 ( ;o) ).

However, I tried using the VNC install option, as presented by the installer 
and that allowed me to configure what I wanted and a seemingly okay vm 
resulted, so I would say there is a bug in the non-graphical/non-vnc installer 
of Fedora 11.

I still don't get all usual the kernel output until it got to the interactive 
part, but that may be normal on Fedora 11.

Thanks again.

>From: Boris Derzhavets <bderzhavets@xxxxxxxxx>
>To: xen-users@xxxxxxxxxxxxxxxxxxx; Ian Murray <murrayie@xxxxxxxxxxx>
>Sent: Tuesday, 25 August, 2009 16:22:44
>Subject: Re: [Xen-users] Creating a  Fedora 11 DomU
>Install from local Apache Mirror provides all options.
># mount -o loop f11.iso /var/www/html/f11
>Point virt-install or virt-manager to  --location http:/IP-Dom0:/f11
>--- On Tue, 8/25/09, Ian Murray <murrayie@xxxxxxxxxxx> wrote:
>>From: Ian Murray <murrayie@xxxxxxxxxxx>
>>Subject: [Xen-users] Creating a  Fedora 11 DomU
>>To: xen-users@xxxxxxxxxxxxxxxxxxx
>>Date: Tuesday, August 25, 2009, 9:33 AM
>>Hi All,
>>I just tried to create a DomU using the following method... (I normally use 
>>the Xen install kernel when I create CentOS domus, but when I tried
>> that with the PXE image, that had the same effect as below). This is the 
>> first time I have created a Fedora domu in ages... years, even.
>>virt-install \
>>              --paravirt \
>>              --name demo \
>>              --ram 500 \
>>              --file /xen/demo.img \
>>              --file-size 6 \
>>              --nographics \
>>              --location 
>> http://mirror.ox.ac.uk/sites/download.fedora.redhat.com/pub/fedora/linux/releases/11/Fedora/x86_64/os/
>>Whilst it worked, I got no chance to set any packages and I ended up with a 
>>pretty empty domu,
>> with no networking, etc. In fact, examining the console I don't get much in 
>> the way of output, compared to me CentOS domu's.
>>PCI: Fatal: No config space access function found
>>IO APIC resources could be not be allocated.
>>        Welcome to Fedora 
>>        Press 'I' to enter interactive startup.
>>Starting udev: [  OK  ]
>>Setting hostname localhost.localdomain:  [  OK  ]
>>mdadm: No arrays found in config file or automatically
>>Setting up Logical Volume Management:   2 logical volume(s) in volume group 
>>"VolGroup" now active
>>[  OK  ]
>>Checking filesystems
>>Checking all file systems.
>>[/sbin/fsck.ext4 (1) -- /] fsck.ext4 -a /dev/mapper/VolGroup-lv_root 
>>/dev/mapper/VolGroup-lv_root: clean, 17225/310688 files, 169285/1242112 blocks
>>[/sbin/fsck.ext3 (1) -- /boot] fsck.ext3 -a /dev/xvda1 
>>/dev/xvda1: clean, 36/51200 files,
>> 20599/204800 blocks
>>[  OK  ]
>>Remounting root filesystem in read-write mode:  [  OK  ]
>>Mounting local filesystems:  [  OK  ]
>>Enabling /etc/fstab swaps:  [  OK  ]
>>Entering non-interactive startup
>>ip6tables: Applying firewall rules: [  OK  ]
>>iptables: Applying firewall rules: [  OK  ]
>>Starting auditd: [  OK  ]
>>Starting system logger: [  OK  ]
>>Starting system message bus: [  OK  ]
>>Starting sshd: [  OK  ]
>>Starting exim: [  OK  ]
>>[  OK  ] crond: [  OK  ]
>>Fedora release 11 (Leonidas)
>>Kernel on an x86_64 (/dev/hvc0)
>>localhost.localdomain login:
>>I've had a quite a google and couldn't really figure out what I am doing 
>>wrong. I am sure I am doing something stupid, so please put me out of my 
>>misery. I think I have been living in a
>> CentOS comfort zone for too long!
>>Thanks in advance,
>>Xen-users mailing list

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>