This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] storage is not detected during guest OS install

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] storage is not detected during guest OS install
From: Barny Kadlecsik <xen@xxxxxxxxxxxx>
Date: Wed, 29 Jul 2009 21:51:53 +0200
Delivery-date: Wed, 29 Jul 2009 12:52:28 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20090605)

I am running Xen (3.2-1-amd64) on Debian (Lenny) and have the following problem. I installed Openfiler (from tarball) and works like a charm, both with file and logical volume backed storage. However, when I tried to run Enterprise Linux (Oracle), no matter how and which kind of storage was defined for the guest system, it didn't recognize during install. I also tried to install Debian, same problem. Neither logical volume, nor file based storage detected during install, so even if both of the guest systems are booting flawlessly, practically I'm with a diskless system. This is the config file I used with Debian:

name            =       'debmed'
kernel          =       '/usr/lib/xen-3.2-1/boot/hvmloader'
builder         =       'hvm'
bootloader      =       '/usr/lib/xen-3.2-1/bin/pygrub'
memory          =       '512'
disk            =       [ 'file:/xenimagefs/debmed.img,xvda1,w',
'file:/xenimagefs/debian-502-amd64-netinst.iso,hdc:cdrom,r' ]
boot            =       'dc'
vif             =       [ "mac=00:3e:3e:3e:3e:75,bridge=eth0,type=ioemu" ]
on_poweroff     =       'destroy'
on_reboot       =       'restart'
on_crash        =       'restart'
vncdisplay      =       '3'

No useful hints in the logs, except this one (it means nothing to me, but maybe rings a bell for somebody):

"I/O request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0"

This is the last entry after booting the guest OS, I always got this one whether I tried to use logical volume as storage, or file. Since I almost has no experience with Xen, chances are that I did something wrong; all hints/comments are appreciated!


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>