This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] I am at wits end, building xen-3.4.0 and always getting Not

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] I am at wits end, building xen-3.4.0 and always getting Not Xen-Elf On Boot
From: Ibrahim Amon <ibrahimamon@xxxxxxxxx>
Date: Wed, 22 Jul 2009 08:23:42 -0700 (PDT)
Delivery-date: Wed, 22 Jul 2009 08:25:23 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s1024; t=1248276222; bh=5h4uUVI6+tMMMa4kJ6kEJk7GVhDTs7IZBM2eYMoJRtw=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type; b=uWowkNv4FsFd+QEGMOvueraIHEHN+gZNrqW5oBx0YGuu0IRXTa5bjcWO6ncNzo2iHbwQzXHoj0k5uOPleflO+faDrI7wTVBRq4dM7VSLKQ6VT90mJAsNytgYbqsI06EHzeiIpalgMMamm4S7ibr1CUVSZQ5OU9lCQ/NzoCJCfvo=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type; b=JsBbK3lxJLAFkGWUaSaCdDDoxp9lUpPE7jxwsFZzJoFYsr23h2HoxIIKLGvXUGoVgKk7IV6DRHqqRcMWdzHmPUvUT4YD3Wj/m5XRPNhB+al4qxyeJtL/k0YDsfpa/GShHR0NGUsulWddnrXKgFD9buYGnzJHgXiZFT8KtYROFHY=;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi All,
I am trying to build xen using a custom kernel and a custom config.  It builds successfully but whenever I add it to my grub.conf and reboot, I always get a kernel panic when xen tries to start dom0 with a message Not Xen-Elf.   I have searched this mailing list and google extensively and have not found anything applicable.  Others have reported similar messages but none of the results seem to apply.   These are the steps that I have taken:
1)  Copied my custom kernel source named linux- to my xen build directory.
2)  Cleaned my custom kernel by removing the .config file and deleting the include/config directory
3)  Ran the following make command:
make dist LINUX_VER="" KERNELS="linux-2.6-xen linux-2.6-xenU" CONFIGMODE=oldconfig IMAGE_TARGET=vmlinux XEN_LINUX_SOURCE=tarball
I tried make world, but that deleted my kernel source directory and attempted to download a new kernel (understandably since it does a make clean first, so I stopped using that target).
I also tried building with IMAGE_TARGET=vmlinuz but build failed stating ~ No such target
I also tried building with IMAGE_TARGET=bzImage but that also failed when booting (can't remember the failure message now, but I believe it was the same Not Xen-Elf failure)
So I have been using vmlinux as IMAGE_TARGET.
4)  Everything builds correctly.  I copied the generated vmlinuz- and its System.map file along with the xen-3.gz symbolic links and xen-3.4.0.gz files to boot.
5)  Modified my grub.conf and added the following:
title CentOS (
  root (hd0,0)
  kernel /xen-3.4.0.gz
  module /vmlinuz- ro root=/dev/VolGroup00/LogVol00 rhgb quiet
  module /initrd-
I initially tried it w/o building the initrd just to see if it would atleast boot the dom0 but that failed with the Not Xen-Elf message.  So I added the initrd and failed with the exact same message.
I have googled and searched this mailing-list till I am blue in the face and still can't get pass this.  I have tried the exact same installation on both my laptop at home and my desktop at work and in addition tried xen-3.3.1 with the exact same result.  Please, anyone, what is going on?  What am I doing wrong?  I am excited about Xen and would really like to get this working.
Thanks if advance,

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>