This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Kernel BUG at drivers/xen/netfront/netfront.c:783

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Kernel BUG at drivers/xen/netfront/netfront.c:783
From: Danilo Godec <danilo.godec@xxxxxxxxx>
Date: Wed, 22 Jul 2009 11:42:57 +0200
Delivery-date: Wed, 22 Jul 2009 02:43:40 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20090605)

I have a RHEL5 based Xen server. Today I tried to install a new SLES10
SP2 DomU and had many troubles. First I tried to install in fully
virtualized mode and at first it seemed fine - I got the VNC windows, I
could select the installation options, but when it should start
installing, it would simply freeze.

So I installed SLES 10 DomU on my local OpenSuSE 11.1 based Xen servers
in paravirtualized mode (this is how I'd like to run the VM) and
transferred the files to the remote Xen server.

Again this seems to work initially - the DomU boots up, I can log in vie
the Xen console, but when I try to activate the network, I get this:

> ----------- [cut here ] --------- [please bite here ] ---------
> Kernel BUG at drivers/xen/netfront/netfront.c:783
> invalid opcode: 0000 [1] SMP
> last sysfs file: /class/net/eth0/type
> CPU 1
> Modules linked in: loop dm_mod ext3 jbd xennet edd processor xenblk
> Pid: 2340, comm: ip Not tainted #1
> RIP: e030:[<ffffffff88017452>]
> <ffffffff88017452>{:xennet:network_alloc_rx_buffers+519}RSP:
> e02b:ffff880056551d18  EFLAGS: 00010286
> RAX: 0000000000000000 RBX: ffff88005d701980 RCX: 0000000000000240
> RDX: 0000000000000000 RSI: 0000000000000000 RDI: 0000000000001200
> RBP: 0000000056f1e000 R08: 0000000000000000 R09: 00000000000536e1
> R10: 0000000000000000 R11: 0000000000000001 R12: ffff880002d28500
> R13: 0000000000056f1e R14: ffff880002d28620 R15: ffff880002d2a6d0
> FS:  00002ad033dafae0(0000) GS:ffffffff803b9080(0000)
> knlGS:0000000000000000
> CS:  e033 DS: 0000 ES: 0000
> Process ip (pid: 2340, threadinfo ffff880056550000, task ffff880002de87d0)
> Stack: ffff88005d4b3978 ffff880002d28000 ffff8800011fe000 ffffffff00005ed0
>        0000000100000240 ffff88005cada838 0000000000000001 00000000560e9140
>        ffff8800560e9140 ffffffff8015cd12
> Call Trace: <ffffffff8015cd12>{filemap_nopage+406}
> <ffffffff8801a042>{:xennet:network_open+68}
>        <ffffffff80284fe0>{dev_open+56}
> <ffffffff8028304e>{dev_change_flags+89}
>        <ffffffff802c76db>{devinet_ioctl+569}
> <ffffffff8027b6da>{sock_ioctl+485}
>        <ffffffff801905dd>{do_ioctl+33} <ffffffff8019086f>{vfs_ioctl+584}
>        <ffffffff801908e9>{sys_ioctl+100}
> <ffffffff8010a1f4>{system_call+104}
>        <ffffffff8010a18c>{system_call+0}
> Code: 0f 0b 68 15 b7 01 88 c2 0f 03 48 63 ea 49 8d bc 24 78 15 00
> RIP <ffffffff88017452>{:xennet:network_alloc_rx_buffers+519} RSP
> <ffff880056551d18>
>  <0>Kernel panic - not syncing: Aiee, killing interrupt handler!

Now I'm not sure - is this a problem of the DomU or could it be the Dom0
or even Xen hypervisor?

 Thanks, Danilo

Xen-users mailing list