This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Trouble starting network on dom0

To: Xen-Users <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Trouble starting network on dom0
From: Nicolas Muñoz <nicolas.munoz.zz@xxxxxxxxx>
Date: Tue, 21 Jul 2009 11:25:50 +0100
Delivery-date: Tue, 21 Jul 2009 03:27:14 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:date:message-id:subject :from:to:content-type; bh=iv2iooubn5dhJhFvwjQQjq3s74T9pGwWT1IabOrtGAc=; b=kAs7a7pT/RxEE6t5CdPXHlUvTdrrFev38sj/suShR0UadbGfRIPuukMkJoK8i4mE5i R0Vmbla7FFJLcJKFCpATbdQ4MLZHkRjR2Fn5DfIXW4rxoljeP65qnzFbfuA8k7zwGtwW nJ/X8RohFzpmi/ADX4TVIIxBsBD23xz+9QTpg=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=kR+onN6xrj14Iu3+tzRyjML13dqUgow1Vo1HLi1XLG5iNjhKq3yYYYxNE2g4f4XX+L iLgfY13iqsz27sWgs/yX31TXDl5CKZG7sKxLcl3cesJUBR3uG926Fjmcoieufu361HqD qE8V5tp+nxzi+iKGAJj4yf/Km1NarAEY37IRM=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

I just managed to install the latest version of xen unstable with kernel with vTPM support following this tutorial : http://cybione.org/~cdidier/blog/200812020841.html

Worked great, except for some little things in sym_crpyto.c & buffer.c where I had to replace TPMTRYRETURN function by another structure (comparing return result of function judged by TPMTRYRETURN to TPM_SUCCESS)
Anyway, works now, but when I'm booting my dom0, even when I'm trying to install my NIC drivers, I cant get any networking. This is pretty annoying, as I cant join the TPM neither...

When I boot, i see several messages about

"disagrees about version of symbol" blah blah..

I noticed it for usbcore, but I dont use usb for now, so it can wait, if I type dmesg, all the messages contain the previous error, but do all concern ipv6. Here is an example of those messages :

ipv6: Unknown symbol inet_csk_destroy_sock
ipv6: disagrees about version of symbol of inet_csk_destroy_sock

I tried to activate some extra options in my kernel, in the networking part, but seems to be useless.
I read somewhere that this message suggests that I compiled things for an older kernel than the one I am actually using, but I am not sure I understand the exact meaning of this...

Any help will be appreciated.

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Trouble starting network on dom0, Nicolas Muñoz <=