This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: No filesystem could mount root

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Re: No filesystem could mount root
From: Peter Mellon <knascent@xxxxxxxxx>
Date: Wed, 8 Jul 2009 13:35:30 -0400
Delivery-date: Wed, 08 Jul 2009 10:36:21 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type :content-transfer-encoding; bh=upt4nS1n9SaZ1/FWCZehJNlJBC3nKIwr1kTMnHTck1E=; b=RhPDgfGCOp6yWfUwxP66nJXz1t51VB+kYEFCYIM06J3EBCz4KMfrVwFELlxZ4pZsPa MO8c+Kjve/3IFr/AE6l1CDPQQCkgzxxkzn+PEiMqravjFIYbUwqLXzWIT2+MGjmiymKV 6NUT/D6pHoYJCyEtKGa+vBu/lyB5AdL+pL/nI=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type:content-transfer-encoding; b=PXzqaTowGchK0YQZYdYL04EFnnUJdMyMWDHqclQ/P71uaE+qLCQi19NW8VNQ9WsWem Wi3jBwUZcZp3mOykeIZ28dTTs8s5Rcecih9wYKvRc2CQRmghhMt2h4J39faUBiIqqqhf rL+/j+ArtipNRewfccej7sNM1TLj1cEZPF2t4=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <996ff9ae0907080906j1fad76a9hba9d9ce15700704c@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <996ff9ae0907080851g58b576f4saba7fa431dd0c961@xxxxxxxxxxxxxx> <996ff9ae0907080906j1fad76a9hba9d9ce15700704c@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Sorry, me again. I think I know why this is happening. The image file
I'm using as a disk has two partitions on it (I'm guessing one for
boot loader and one for is the main partition?)

[root@localhost xen]# fdisk -lu /home/xen/image
    Device Boot      Start         End      Blocks   Id  System
imagep1   *          63      208844      104391   83  Linux
imagep2          208845    20466809    10128982+  8e  Linux LVM
Partition 2 has different physical/logical endings:
     phys=(1023, 254, 63) logical=(1273, 254, 63)

And its not booting because I'm trying to put the entire file on
domU's sda1 rather than just that second partition. I tried making it
/dev/sda instead of sda1 (even though I'm pretty sure thats not the
right way to do it) and now a new error happens during boot:
EXT3-fs: mounted filesystem with ordered data mode.
Kernel panic - not syncing: Attempted to kill init!

Slow progress, but I'm getting closer :-). Anyone know how I can set
up the partitions correctly from an image file and boot from it?


On Wed, Jul 8, 2009 at 12:06 PM, Peter Mellon <knascent@xxxxxxxxx> wrote:
> Hello again,
> I just realized what the problem was. I didn't specify a 'ramdisk' option in 
> my config file. I told it to use the same initrd as the dom0 and I got a 
> little further in the domU boot, but now I have this error message:
> -------
> VFS: Can't find ext3 filesystem on dev sda1
> Kernel panc - not syncing: Attempted to kill init!
> ------
> Anyone know how I can fix this?
> Thanks a lot
> On Wed, Jul 8, 2009 at 11:51 AM, Peter Mellon <knascent@xxxxxxxxx> wrote:
>> Hello,
>> I've finally been able to install Xen (version 3.4 with kernel 2.6.18) and 
>> booted the xen kernel. Now I'm trying to create a VM that uses an image file 
>> as its disk, but a few seconds after I boot the VM it stops with this 
>> message:
>> [root@localhost xen]# xm create -c xmexample1 vmid=1
>> ......
>> No filesystem could mount root, tried:  ext2
>> Kernel panic - not syncing: VFS: Unable to mount root fs on 
>> unknown-block(8,1)
>> Here is the config file:
>> -------------------------------
>> kernel = "/boot/vmlinuz-"
>> memory = 400
>> name = "ExampleDomain"
>> vcpus = 4
>> vif = [ 'mac=00:16:3e:00:01:01, bridge=br0' ]
>> disk = [ 'file:/home/xen/image,sda1,w' ]
>> root = "/dev/sda1 ro"
>> extra = "4"
>> --------------------------------
>> That image, /home/xen/image, was created by a previous Xen installation (it 
>> came with my Fedora 7 distro with virt-manager, so I did not have to manage 
>> config files. I want to boot from it again using the newest Xen)
>> Thanks

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>