This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen Virtual Machine Pointer problem

To: Andreas Sommer <AndiDog@xxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Xen Virtual Machine Pointer problem
From: anitha rn <anithaashok16@xxxxxxxxx>
Date: Tue, 7 Jul 2009 17:44:38 +0530
Delivery-date: Tue, 07 Jul 2009 05:15:20 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type :content-transfer-encoding; bh=lY0A9dmE/DwUDBGAxAZj3kqXjgSto/VsJRUqCMibjzg=; b=CEgoLv1wmPNBjSKoP0Ap80D8M7vgyR35QFs1CZO7+zAZqWVbg/WvN4tlgG6YfPnfrR iO4MDgm0qu31I38wTouqn9pOCVCsi5EfEsnLkSmRVNQIqHUQHvklj0ps1flQkcH0PHq3 FAHtXdHAYlnRAGM/E/5TXMtVnySQcH5DInCVM=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type:content-transfer-encoding; b=t8qAe/r1V+Q9lXf3KgxaARBurJl3XacB1yqsPNrsDsmxYIgL25vmQdsBrBUoCRZ78U eRbveLYvVjith/qae+gzE02Vn+HdtC22bM/Om71JcFG6FRJco5+XhJ+p6kpoSefSgPwi a15nQyvfn+nVAXshux18h/n5tLLaKfH0csFQ8=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4A531A69.1000800@xxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <b33b9cb70907060337u1a379d1bufa0e78e6512c8121@xxxxxxxxxxxxxx> <4A524F5D.9090400@xxxxxx> <b33b9cb70907062140q5f5985f7ge712b29306679a8@xxxxxxxxxxxxxx> <4A531A69.1000800@xxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thanks a lot Andreas....
Your solution worked out for me exactly.....
I m really thankful to you....

Thanks and Regards
 Anitha : -)

On Tue, Jul 7, 2009 at 3:20 PM, Andreas Sommer<AndiDog@xxxxxx> wrote:
> PLEASE always reply to the mailing list, too!
> As to your problem: The tutorial I sent you works for me. Make sure to check
> the input devices on the domU with
> cat /proc/bus/input/devices
> That command will show you which event belongs to the emulated mouse, e.g.
> event3 --> /dev/input/event3. This has to be entered in the Xorg
> configuration. You have to configure the domU with
> usb=1
> usbdevice="tablet"
> in order to have an absolute mouse position. Instead of entering the device
> yourself, you can also try the following
> Section "InputDevice"
>    Name "Mouse0"
>    Driver "evdev"
>    Option "Name" "QEMU 0.8.2 QEMU USB Tablet"
>    Option "Mode" "Absolute"
>  EndSection
> Of course "Mouse0" then has to be entered in the ServerLayout section.
> Hope this helps.
> anitha rn wrote:
> Hi..
> Thanks for your response... i ve tried with the link which you pointed
> to me. But its not working. Also i ve googled a lot,but not getting to
> know how to solve it. Kindly point me the solution.
> My Virtual Machine is Fedora 8.
> The vm Configuration file is of type vnc.
> I m using an image file to start the Virtual Machine.
> On Tue, Jul 7, 2009 at 12:54 AM, Andreas Sommer<AndiDog@xxxxxx> wrote:
> This is because the emulated mouse gives relative movements and not absolute
> pixel coordinates. You can change it to emulation of a USB tablet device
> which sends these absolute values. Just search the Internet, there are
> multiple solutions. For example
> http://os-drive.com/files/docbook/xen-mouse.html.
> anitha rn wrote:
> Hello All...
> I have installed xen 3.3.
> I m running a Virtual Machine using an image file that has fedora 8
> installed in it.
> When i view the Virtual Machine using VNC Viewer or on the browser
> using tight vnc,there appears
> 2 pointers .I need to solve this problem. Kindly suggecst me the
> correct solution.
> Waiting for responses.

Thanks and Regards

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>