This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] xen-tools: does not unmount disks and mounts proc into t

To: Alexander Menk <alex.menk.lists2@xxxxxxxxxxxxxx>
Subject: Re: [Xen-users] xen-tools: does not unmount disks and mounts proc into the new VM - why?
From: Mike Lovell <mike@xxxxxxxxxxxx>
Date: Wed, 01 Jul 2009 18:54:58 -0600
Cc: Xen User-List <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Wed, 01 Jul 2009 17:55:43 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1246430226.31355.98.camel@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <1246430226.31355.98.camel@xxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20090608)
Alexander Menk wrote:

I am using xen-tools version: 3.9-4 to create domUs:

1. time xen-create-image --verbose --dist=lenny
 --hostname dummy --ip xxx.xxx.xxx.xxx --force

2. xm create dummy.cfg

Then I get the message
Device /dev/vg0/dummy-disk is mounted in the privileged domain,
and so cannot be mounted by a guest.

3. When I tried to umount, I got "device busy".

4. I am really surprised about the output of mount on my dom0:

dom0:~# mount
/dev/sda1 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/mapper/vg0-linux--images on /mnt/linux-images type xfs (rw)
/dev/mapper/vg0-xen--file--images on /mnt/xen-file-images type xfs (rw)
/dev/mapper/vg0-dummy--disk on /tmp/1UNYuVP7WO type ext3 (rw)
/proc on /tmp/1UNYuVP7WO/proc type none (rw,bind)

Why is /proc mounted to /tmp/1U.... that is in fact the disk of the new
VM? That looks really dangerous.
Did anybody see this before?

I used --force because on the first call I did a mistake and the logical
volumes already existed. Maybe --force is not a good idea?

I would check to see if a process, like sshd, got started in the chroot that xen-tools created. Having something running there could keep the host from being able to unmount the volumes. I ran into this problem and it was something starting in the chroot. Hope that helps.


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>