This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] problem with xm create

To: Xen-users@xxxxxxxxxxxxxxxxxxx
Subject: RE: [Xen-users] problem with xm create
From: elli_dberg@xxxxxx
Date: Wed, 01 Jul 2009 12:33:08 +0200
Delivery-date: Wed, 01 Jul 2009 03:33:50 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: http://freemail.web.de/
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi Ian,

the sata drivers are compiled into the kernel.
However, I fixed the problem and I can start the guest domain with xm create. 
The problem was that I have messed up something with LVM so it wasn't working 
properly. I created a new guest domain instance with loopback image and all is 

Thanks to the numerous answers and help.

"Ian Tobin" <itobin@xxxxxxxxxxxxx> schrieb am 30.06.2009 19:02:12:

Did you set your dom u config to use a RAM disk or are the sata drivers 
complied into the kernel?

-----Original Message-----
From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx 
[mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of elli_dberg@xxxxxx
Sent: 30 June 2009 13:02
To: Andreas Sommer
Cc: Xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] problem with xm create

Hi Andreas, and everyone,

I did as you said and I set extra= "xencons=tty". Now the boot precess goes 
some more lines further but now there is another problem. These are the last 
lines of the output of xm create -c ...

fuse init (API version 7.7)
Begin: Running /scripts/init-premount ...
Begin: Mounting root file system... ...
Begin: Running /scripts/local-top ...
Begin: Waiting for root file system... ...
chvt: can't open console
chvt: VT_ACTIVATE: Bad file descriptor
Gave up waiting for root device.  Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
chvt: can't open console
chvt: VT_ACTIVATE: Bad file descriptor
ALERT! /dev/sda1 does not exist. Dropping to a shell!

BusyBox v1.10.2 (Ubuntu 1:1.10.2-1ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands.


Does that mean that the virtual machine cannot recognize the file system? I 
have a SATA hard drive and I am using the same kernel and setup as for dom0. I 
tried also specifying the root device as its UUID but didn't work neither.
Do have any idea?

Thank you 

Andreas Sommer <AndiDog@xxxxxx> schrieb am 30.06.2009 12:53:02:
Check if "xm list" shows you a running state ("r" for running or "b" for 
booting, "p" often means that an error occurred). I guess you might have 
forgotten the line

extra = ''xencons=tty"

so the domU seems to hang because it doesn't show the login prompt on 
the correct console.

Compare to this thread: 

elli_dberg@xxxxxx wrote:
> Hi,
> I am having troubles starting a domU. I run it with: xm create -c 
> config_file. Then I can see the output and it seems as if everything is going 
> well. Then, the output suddenly stops without any failures and there is 
> nothing I can do. The cursor is blinking but not responding to any keyboard 
> inputs. I even cannot kill the process with ctrl+c. When I run 
> xen-list-images it shows the image: 
> $ xen-list-images
> Name: virtualrouter1
> Memory: 128
> IP:
> Here is the output of xm create:
> Using config file "./virtualrouter1.cfg".
> Started domain virtualrouter1 (id=2)
> Bootdata ok (command line is root=/dev/sda1 ro )
> Linux version (root@virtualrouter1) (gcc version 4.3.2 (Ubuntu 
> 4.3.2-1ubuntu12) ) #2 SMP Wed Jun 24 14:11:03 CEST 2009
> BIOS-provided physical RAM map:
>  Xen: 0000000000000000 - 0000000010800000 (usable)
> No mptable found.
> Built 1 zonelists.  Total pages: 66660
> Kernel command line: root=/dev/sda1 ro 
> Initializing CPU#0
> PID hash table entries: 2048 (order: 11, 16384 bytes)
> Xen reported: 3000.680 MHz processor.
> Console: colour dummy device 80x25
> Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
> Inode-cache hash table entries: 32768 (order: 6, 262144 bytes)
> Software IO TLB disabled
> Memory: 231424k/270336k available (2585k kernel code, 30416k reserved, 1122k 
> data, 192k init)
> Calibrating delay using timer specific routine.. 6002.56 BogoMIPS 
> (lpj=30012826)
> Security Framework v1.0.0 initialized
> Capability LSM initialized
> Mount-cache hash table entries: 256
> CPU: L1 I cache: 32K, L1 D cache: 32K
> CPU: L2 cache: 6144K
> CPU: Physical Processor ID: 0
> CPU: Processor Core ID: 0
> SMP alternatives: switching to UP code
> Freeing SMP alternatives: 28k freed
> Brought up 1 CPUs
> migration_cost=0
> checking if image is initramfs... it is
> Freeing initrd memory: 20068k freed
> NET: Registered protocol family 16
> Brought up 1 CPUs
> PCI: setting up Xen PCI frontend stub
> ACPI: Interpreter disabled.
> Linux Plug and Play Support v0.97 (c) Adam Belay
> pnp: PnP ACPI: disabled
> suspend: event channel 6
> xen_mem: Initialising balloon driver.
> SCSI subsystem initialized
> PCI: System does not support PCI
> PCI: System does not support PCI
> NET: Registered protocol family 2
> IP route cache hash table entries: 4096 (order: 3, 32768 bytes)
> TCP established hash table entries: 16384 (order: 6, 262144 bytes)
> TCP bind hash table entries: 8192 (order: 5, 131072 bytes)
> TCP: Hash tables configured (established 16384 bind 8192)
> TCP reno registered
> IA-32 Microcode Update Driver: v1.14a-xen <tigran@xxxxxxxxxxx>
> audit: initializing netlink socket (disabled)
> audit(1246352198.193:1): initialized
> VFS: Disk quotas dquot_6.5.1
> Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
> Initializing Cryptographic API
> io scheduler noop registered
> io scheduler anticipatory registered
> io scheduler deadline registered
> io scheduler cfq registered (default)
> rtc: IRQ 8 is not free.
> Non-volatile memory driver v1.2
> RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
> loop: loaded (max 8 devices)
> e1000e: Intel(R) PRO/1000 Network Driver -
> e1000e: Copyright (c) 1999-2008 Intel Corporation.
> Intel(R) Gigabit Ethernet Network Driver - version 1.2.45-k2
> Copyright (c) 2008 Intel Corporation.
> ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version
> Copyright (c) 1999-2008 Intel Corporation.
> Xen virtual console successfully installed as xvc0
> Event-channel device installed.
> blktap_device_init: blktap device major 254
> blktap_ring_init: blktap ring major: 253
> netfront: Initialising virtual ethernet driver.
> vif vif-0: 2 parsing device/vif/0/mac
> vif vif-1: 2 parsing device/vif/1/mac
> vif vif-2: 2 parsing device/vif/2/mac
> Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
> ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
> st: Version 20050830, fixed bufsize 32768, s/g segs 256
> osst :I: Tape driver with OnStream support version 0.99.4
> osst :I: $Id: osst.c,v 1.73 2005/01/01 21:13:34 wriede Exp $
> aoe: aoe_init: AoE v22 initialised.
> PNP: No PS/2 controller found. Probing ports directly.
> i8042.c: No controller found.
> mice: PS/2 mouse device common for all mice
> md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
> md: bitmap version 4.39
> NET: Registered protocol family 1
> NET: Registered protocol family 17
> PCI IO multiplexer device installed.
> XENBUS: Device with no driver: device/console/0
> BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
> EDD information not available.
> Freeing unused kernel memory: 192k freed
> fuse init (API version 7.7)
> What could be the problem? Appreciate any help.
> Thank you,
> Elisabeth 
GRATIS für alle WEB.DE-Nutzer: Die maxdome Movie-FLAT!
Jetzt freischalten unter http://movieflat.web.de

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>