This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Can't ping gateway (SOLVED !!!!)

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Can't ping gateway (SOLVED !!!!)
From: Mark Lancaster <marklanc@xxxxxxxxx>
Date: Wed, 27 May 2009 12:34:00 -0700
Delivery-date: Wed, 27 May 2009 12:34:44 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:date:message-id:subject :from:to:content-type; bh=4B99jVi3Jp3xMETd09zW8jWTiFDelfdtr6Eji9m88aA=; b=CuMGCKAc/98KCQhzANawgqWIm/o4HZhb/Pgg0q0U8X/Fk7mR+CcNLq/sNPo8E1XOf+ VvCZYPY56h7v66wZ6KArW2w6vjXHkH0WqMfFiioKFZbPhV8oY8yxg0FDWf4rYkNZ7OZX gM7Q2Fi1HLbg0imHo+XN/d121/fCnyKEEIAbw=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=rGz9KGraMYI2ocLuacbUG/f29MxcmUSn5b/BVDhlMmkY/CVcByrqiHHi7X+UJiVv2r F0tk1lkHbgvA/oOgFklq4x03Xfne2aZX167JQXtWZWKGJaFI/nQnNx7yTygBZKy8y+cO THv86vulY+FZIe6veyK6q0D24ueAtgmeE6rpE=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
from:  http://www.centos.org/modules/newbb/print.php?form=1&topic_id=19489&forum=40&order=ASC&start=0

"I just found out that there is setting in the BIOS which is Realtek LAN Boot ROM. It is not enabled and therefore the MAC address is kept on overwritten. After setting it to enabled, I got my real MAC address back and xen works as per normal."

Confirmed the above, and networking working again as normal.



Message: 1
Date: Wed, 27 May 2009 16:53:27 +0000
From: "Jk ." <jankarlitos@xxxxxxxxxxx>
Subject: [Xen-users] Can't ping gateway (SOLVED !!!!)
To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Message-ID: <COL107-W1E891CCBF89E84CEB0FC6BF530@xxxxxxx>
Content-Type: text/plain; charset="iso-8859-1"

HI again,

This is the solution to my problem, hope it helps someone in the future.

First of all, thanks to Ramachandran Radhakrishnan for helping me with this.

The problem was my NIC: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

What happens, is that the NIC's driver sets the HWADRRESS = FE:FF:FF:FF:FF:FF, and that's the same address used in xenbr0

What you need to do, is set the address manually. in Centos you can do this by setting /etc/sysconfig/network-scripts/ifcfg-eth0

you need to set MACADDR=00:00:de:50:f1:45 (just an example)

be sure you set MACADDR and not HWADDR

and that's it !!!!  thanks, to everyone... now i can continue my virtualization process...

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>