This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] Using Xen on load balancer keeps loosing connection

To: "'Peter Booth'" <peter_booth@xxxxxxx>
Subject: RE: [Xen-users] Using Xen on load balancer keeps loosing connection
From: Tom Potwin <wxman2@xxxxxxxxx>
Date: Tue, 26 May 2009 12:03:35 -0400
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 26 May 2009 09:05:30 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:reply-to:from:to:cc :references:in-reply-to:subject:date:organization:message-id :mime-version:content-type:x-mailer:x-mimeole:thread-index; bh=+fC+KiNzHe5SdEbGYzhkpARdsWwk5t2nf+btQLHhP6E=; b=vAplnftc270XimYwnH2UML/Me+jBy23piQUwZ2s2zRyTHBErT4re5BmWrO1frMNUfP eeiGSn/Aev3MaGPYk8PhWtsbuWT+VqFF8nBwDzWl+faQUNTlRNxa0GAzIm+uzWkyy+Mi 50kEtkAbsOl4KvEy9kjhme+K9rzCCJwIBCVNI=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=reply-to:from:to:cc:references:in-reply-to:subject:date :organization:message-id:mime-version:content-type:x-mailer :x-mimeole:thread-index; b=klbf6v47QZh7/9pBzzhs5/iFAIoBcE5a4r4RHPJP815chE2vYwjNW1o1YMclV/oBDH nYCr1W8525ABNqvK4h2h8bj1CQv4fZFSH5Bgr5mh+XG007UgF9YgoxpIXP4gXTVdcFL1 SYUBwlGCiCEoYUm77akbAUp9iEPQu/i5R7Rac=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <2330E3D3-3252-4918-B512-6B938AFE7B30@xxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: The Literary Times
References: <BAD691A055644486A255E2E9485BD513@tomPC> <2330E3D3-3252-4918-B512-6B938AFE7B30@xxxxxxx>
Reply-to: littimes@xxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: Acndje1ppt8wLVSQRQqq/7llEwEotAAi8qow
Hi Peter

To answer your questions, yes, it is going to be a working server setup.
Before I go any further, I guess I had better ask you first why are you
puzzled that I would use xen? I needed to have two load balancers with auto
failover, and of course two LAMP web servers setup's.

I'm using a router/firewall that sends traffic from my public IP to the
local shared IP Each physical machine has two physical
NIC's. One connects to the router, and the other is just for
replication/mirroring between the two servers. Attached is the cfg for the
LB1 node that seems to be having the problem. Please let me know if I didn't
answer something. I'm still getting used to using xen.


-----Original Message-----
From: Peter Booth [mailto:peter_booth@xxxxxxx] 
Sent: Monday, May 25, 2009 6:55 PM
To: littimes@xxxxxxx
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Using Xen on load balancer keeps loosing connection


A two part response:
1. Can you step back and give some more context? Are you attempting to
simulate a proposed production environment or is this environment one that
you will run in production?

If it's the latter, then I'm puzzled why you'd use xen.

2. How many physical NICs does each server have?
Are you using bridged or routed networking?
How many PCPUs do you have?
how is dom0 and each domu configured for vcpus/caps/weights?


Sent from my iPhone

On May 25, 2009, at 5:40 PM, Tom Potwin <wxman2@xxxxxxxxx> wrote:

> Hi
> I just joined this list after I tried looking for help with the 
> HAProxy, and HA heartbeat people. They're both at a loss as to what's 
> causing my problem.
> The only place I haven't tried is here with the Xen experts. I checked 
> xm info for the version and got this:
> Release : 2.6.24-23-xen
> version : #1 SMP Wed Apr 1 23:47:10 UTC 2009
> I'm using HAProxy and Heartbeat on two Ubuntu 8.04 servers. I have two 
> Xen nodes on each of my physical machines. One is the load balance and 
> Heartbeat (LB1), the other is the actual LAMP web server (WEB1). 
> Testing HAProxy/Heartbeat setup seems that it's working fine, by that 
> I mean that shutting off one of the web servers, it switches to the 
> other one. My problem is I keep loosing access to the HAProxy stats 
> page, which only should show up on the LB nodes where HAProxy is. I 
> know that isn't a huge problem, but I'm worried it might be a sign of 
> a bigger problem somewhere.
> The stats show up fine for about 15-20 minutes, then I get a apache 
> generic
> 404 error page. I also see: "File does not exist:
> /var/www/apache2-default/haproxy" show up in the apache error log on
> WEB1
> node as soon as I loose it. If I go back to my LB1 node and restart 
> Heartbeat, it all comes back for another 15-20 minutes. There's 
> nothing in any of the logs that I can see, other than it stops logging 
> when it happens.
> I use to get to that stats page.  
> The
> .100 is the shared address between the the load balancers. If I use 
>, which is LB1, I get the browser's 404 notice. If I use 
> .100, it shows my apache generic 404 page. So somehow it stops seeing 
> LB1, and goes to port 80 on my web server on the WEB1 node. That's 
> where I see the apache error saying it can't find the HAProxy stats 
> page.
> When I used the "tcpdump -q -i eth0 tcp port 80 and src host 
> "
> command, it showed me looking at the stats, and the test web page:
> tcpdump: verbose output suppressed, use -v or -vv for full protocol 
> decode listening on eth0, link-type EN10MB (Ethernet), capture size 96 
> bytes
> 11:23:16.106664 IP > tcp 0
> 11:23:16.254209 IP > tcp 0
> 11:23:16.254409 IP > tcp 262
> 11:23:16.254501 IP > tcp 0
> 11:23:17.460534 IP > tcp 0
> 11:23:17.628385 IP > tcp 0 
> 11:23:17.628590 IP > tcp 2712
> 11:23:17.839448 IP > tcp 2712 
> 11:23:17.839460 IP > tcp 524
> Once I couldn't see the stats page again, the output stopped 
> completely. I watched it on LB2 as well. It seems like it stops 
> listing to the .
> 100 IP
> address. If I use "tcpdump -q -i eth0 tcp port 80" I see LB1 checking 
> web1 and web2, but nothing on the .100 address. The HAProxy people 
> said they thought it might be a Heartbeat problem, because after they 
> checked my HAProxy setup, they couldn't find any problems there. The 
> heartbeat people say the same thing. Sorry for the long post, I'm just 
> getting desperate for some help.
> Thanks, Tom
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Attachment: lb1.cfg.txt
Description: Text document

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>