This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] GPLPV 0.10.55 net misbehaviour

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] GPLPV 0.10.55 net misbehaviour
From: Andreas Pflug <pgadmin@xxxxxxxxxxxxxxxxx>
Date: Tue, 12 May 2009 19:47:53 +0200
Delivery-date: Tue, 12 May 2009 10:48:27 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20090302)
I'm using W2K2 32bit on a 3.2.1 Lenny-amd64 host. While the pv disk
driver works as expected, I encounter problems with the network driver.
I tried several installation scenarios, all with the same result.
My test looks like this:
I install gplpv, but without letting the networking driver install.
After reboot I RTL8139 ist still active and working, and gplpv devices
manage the disks. Then I click "update driver" on the pv net device, and
after it has been enabled I reboot.
After reboot, the new LAN device is configured for DHCP, which isn't
good for me so I assign IP address, gw and DNS. When clicking OK, I'm
warned about a duplicate IP address (from the dormant RTL8139, as
expected). I accept the duplicity and then the taskbar interface icon 
as well as the status dialog shows "aquiring network address" for ever,
the NIC properties dialog stops to respond, the interface won't come up.
After rebooting the VM another time, network seems to work correctly.

Is gplpv supposed to work like that? I wonder if the XP fix applies to
2003 as well, since I've never seen driver differences between XP and 2003.


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] GPLPV 0.10.55 net misbehaviour, Andreas Pflug <=