This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] Re: [Xen-users] Re: VT-D RMRR is incorrect

To: Yoshiharu Mori <ymori4480@xxxxxxxxx>, Christian Tramnitz <chris.ace@xxxxxxx>
Subject: RE: [Xen-devel] Re: [Xen-users] Re: VT-D RMRR is incorrect
From: Ross Philipson <Ross.Philipson@xxxxxxxxxx>
Date: Sat, 21 Feb 2009 12:14:09 -0500
Accept-language: en-US
Acceptlanguage: en-US
Cc: "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>, "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Sat, 21 Feb 2009 09:14:48 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <d5dec53b0902210858x5c5f094diacd74f5dd8f13a59@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <d5dec53b0902131346t663491d2x37f630dc1e64294b@xxxxxxxxxxxxxx> <gn8o04$1cn$1@xxxxxxxxxxxxx> <d5dec53b0902150423o47306903j4d84c4c558dbd496@xxxxxxxxxxxxxx> <gndp6u$5f5$1@xxxxxxxxxxxxx> <48886.5834581249$1234876425@xxxxxxxxxxxxxx> <gnp6nb$4o7$1@xxxxxxxxxxxxx> <d5dec53b0902210858x5c5f094diacd74f5dd8f13a59@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcmURef5QNyvYGxRTVGAkNm/E+jweAAAKZkw
Thread-topic: [Xen-devel] Re: [Xen-users] Re: VT-D RMRR is incorrect

Hi folks,


This sounds a lot like an issue I am working on right now. A recent change to the vtd code changed the way the 1 to 1 page mapping for dom0 is done (look at intel_iommu_domain_init() for dom0). The change was to query the e820 map for memory regions that were usable RAM and only map those into the iommus for dom0. Thus reserved regions were no longer mapped in. When the RMRR values do not report the correct values for required 1 to 1 reserved memory regions, the needed regions do not get mapped in. Thus device DMA to these regions causes vtd faults and in out case a hang. It is indeed a BIOS bug; perhaps this is the same issue you are seeing?


Anyway, I am working on a workaround that I will be pushing upstream this week. A parameter will allow you to include reserved memory regions in the mappings. It is not ideal (less secure) but better than hanging or crashing…





From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Yoshiharu Mori
Sent: Saturday, February 21, 2009 11:58 AM
To: Christian Tramnitz
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx; xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Re: [Xen-users] Re: VT-D RMRR is incorrect


Hi Christian

Yoshiharu, have you tested Xen-unstable yet? When commenting out the EFAULT you mentioned I get an immediate panic related to the rmrr address conflict on the latest 3.4-unstable tree.


I also tried Xen-unstable, but could not boot xen when I commented out the EFAULT.
(The boot message was too fast and my machine was rebooted soon, I counldn't understand details.)

BTW, I got new BIOS from SUPERMICRO. But I cannot test till next week end.
Another trouble was happend on my board, I sent it to distributor and change it.

@Xen devs: Is this something that could be worked around in Xen or do we really have to rely on exact RMRR values for vtd to work?
See http://permalink.gmane.org/gmane.comp.emulators.xen.user/43937 for more details.


The RMRR regions are expencted to be used only for USB and UMA Graphics legacy usages for reserved memory, I think it may be possible to use vtd with limitation.

Yoshiharu Mori

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>