This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] iptables & kernel problems on Debian domU

To: Rudi Ahlers <rudiahlers@xxxxxxxxx>
Subject: Re: [Xen-users] iptables & kernel problems on Debian domU
From: Thomas Halinka <lists@xxxxxxxxx>
Date: Thu, 19 Feb 2009 23:38:10 +0100
Cc: xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 19 Feb 2009 14:38:52 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <695200da0902191414l216161dkdb7b41cf39027dce@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <695200da0902191414l216161dkdb7b41cf39027dce@xxxxxxxxxxxxxx>
Reply-to: lists@xxxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi Rudi,

i thought you read my book ;)

Am Freitag, den 20.02.2009, 00:14 +0200 schrieb Rudi Ahlers:
> Hi,
> I have a Debian 4.0 XEN dom, which is giving me some strange errors on
> the kernel when I try and use iptables, as such:
> stats:/etc/snmp# iptables -L -v
> Note: /etc/modules.conf is more recent than
> /lib/modules/2.6.18-8.1.15.el5xen/modules.dep
Something strange here

This is not a Debian-Kernel!

> modprobe: QM_MODULES: Function not implemented
> modprobe: QM_MODULES: Function not implemented
> modprobe: Can't locate module ip_tables
> iptables v1.3.6: can't initialize iptables table `filter': iptables
> who? (do you need to insmod?)
> Perhaps iptables or your kernel needs to be upgraded.
> When I run apt-get upgrade, there's no newer kernel to install.
> I also don't see grub anywhere, so I don't know how to manually
> install & load a different kernel at boot time, on the domU. I suppose
> I could just install grub, and a kernel, but I don't know how it will
> affect the VPS.

Again - this is not a Debian-Kernel!

> Can anyone point me into the right direction?

Let me guess that the problem is solved through:

- rebuilding initrd of dom0


- installing the debian-Kernel in _domU_ and altering domu.cfg in


- installing the debian-Kernel in _domU_ and make usage of pvgrub/pygrub
in dom0



Xen-users mailing list