This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] xm block-detach timeout problem

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] xm block-detach timeout problem
From: "Felix Chu" <felixchu@xxxxxxxxxxxxxxxxxxxx>
Date: Wed, 18 Feb 2009 00:43:54 +0800
Delivery-date: Tue, 17 Feb 2009 08:43:56 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcmRHuuO+7S7k7lWTTKuV6wcI4FCEQ==

Hi all,


I am using Centos 5.2 for both DomU and Dom0. I used “xm block-attach” to attach a LV to a DomU and mounted to DomU’s /mnt.


I tried to run “xm block-detach vm1 /dev/sdb”, I find that this command will hold for long time as DomU has not umount /mnt. I have done an experiment by running “time xm block-detach vm1 /dev/sdb”. I find that this command needs 1min 40s to timeout. Any method to shorten this timeout?


[root@localhost] time xm block-detach vm1 /dev/sdb

Error: Device /dev/sdf (vbd) could not be disconnected.

Usage: xm block-detach <Domain> <DevId> [-f|--force]


Destroy a domain's virtual block device.


real    1m40.149s

user    0m0.052s

sys     0m0.044s


P.S. I tried xm block-detach vm1 /dev/sdb –force , this command will result hang of DomU.




Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] xm block-detach timeout problem, Felix Chu <=