This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Unable to set system clock on domU

Hi Fajar.

On Tuesday, 17 February 2009 16:04:41 +0700,
Fajar A. Nugraha wrote:

> >> > /proc/sys/xen/independent_wallclock is set to 0 on dom0. what can
> >> > be happening?
> >
> >> Set it to "1".
> >
> > I tried setting /proc/sys/xen/independent_wallclock to "1" and
> > booting again the domU, but I obtain the same message during boot.
> Sorry, I should've been more specific :)

No problem :-)

> The normal way with xen is that domU follows dom0's clock. You should
> not need to set clock on domU, you simply need to use rtc_timeoffset
> or localtime to adjust (possible) time zone or RTC settings
> differences.

It was the configuration that I was using on domU with
/proc/sys/xen/independent_wallclock set to "0" and tzdata set to
America/Argentina/Buenos_Aires and dom0 synchronizing via ntpdate,
although I don't remember that obtained the message that mentioned in
the initial post with the version that were using previously of the
hypervisor and kernel.
> Some implementantions of ntp init scripts (like the one from RHEL)
> will also try to modify RTC by default during ntp startup. When in
> domU, this will create an error as domU doesn't have RTC. You can
> safely ignore this error though. The error would be something like
> "Syncing hardware clock to system time Cannot access the Hardware
> Clock via any known method.
> Use the --debug option to see the details of our search for an access
> method. [FAILED]"

With /proc/sys/xen/independent_wallclock set to "0", the hour is correct
even though that is observed the message "Unable to Set System Clock
to:...". Perhaps the error message (warning) will be because it cannot
be acceded to the /dev/rtc device since it does not exist.

# hwclock --debug
hwclock from util-linux-ng
hwclock: Open of /dev/rtc failed, errno=2: No such file or directory.
Using direct I/O instructions to ISA clock.
Last drift adjustment done at 1162000000 seconds after 1969
Last calibration done at 1162000000 seconds after 1969
Hardware clock is on UTC time
Assuming hardware clock is kept in UTC time.
Waiting for clock tick...
...got clock tick

> Now I dont't know whether or not Debian modifies RTC, but I think you
> simply need to set /proc/sys/xen/independent_wallclock to "1" on that
> particular domU (again, not dom0).
> My suggestion though is simply set the correct time zone, set
> "locatime" or "rtc_timeoffset" on domU config if necessary, and simply
> run ntpd on dom0.

As I mentioned to you above, timezone is correct with tzdata, reason why
I didn't modify it, and there is a ntpdate in dom0 synchronizing at
regular intervals. Now I added the line "xen.independent_wallclock = 1"
in /etc/sysctl.conf. date command also shows the correct hour,
nevertheless I continue observing the same error message on boot:

Setting the system clock.
Unable to set System Clock to: Tue Feb 17 09:38:08 ARST 2009 (warning).

Thanks for your reply.

Daniel Bareiro - System Administrator
Fingerprint: BFB3 08D6 B4D1 31B2 72B9  29CE 6696 BF1B 14E6 1D37
Powered by Debian GNU/Linux Lenny - Linux user #188.598

Attachment: signature.asc
Description: Digital signature

Xen-users mailing list