This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] xm pci-detach lockup

To: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-users] xm pci-detach lockup
From: "Andrew Lyon" <andrew.lyon@xxxxxxxxx>
Date: Fri, 26 Dec 2008 14:11:16 +0000
Delivery-date: Fri, 26 Dec 2008 06:12:01 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:in-reply-to:mime-version:content-type :content-transfer-encoding:content-disposition:references; bh=Mnteju7wz94+8OKbEqA4oBqUX7YWxX2VB3BVm9ZFKAA=; b=k9CoUs5jyQTa0RT6eOqKcTfmxjVb888XodB4MBRMQTFGVFA9nJrZUC7vyuCjFAkGHt Va5Dp/a9kpKf6VdXSP1WvISXoWXZATuRKibWzunuyM8AY8zRo6B4+ZtyXKdtdukOijWA hYS+CeHCflLlbAiBGbl/odjNshAjqAGH3DWVg=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:in-reply-to:mime-version :content-type:content-transfer-encoding:content-disposition :references; b=e1pVvXJWVUZWkeUj4BQxr4Lq55BN0dJMCXpv5Jx0YY5fJnIjSVBISdIzBsvw45sKV0 OkJCHUALqHEilEyaQUuVUVPWBplYo5lukd9Sipzn7D6hMr+av9RYyAqQV4pENlxp+pfQ YRX+n26UVL48KYBXKuI05KLUKhD8cV52KjcXc=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <f4527be0812230010r62124fa7k4a51d73e942a4d28@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <f4527be0812221058j65c5ba9fj982116ddba99d53e@xxxxxxxxxxxxxx> <f4527be0812221137t33584968qe956c86d61510e77@xxxxxxxxxxxxxx> <1e16a9ed0812222120x10c9206doc5369c1c6cd96742@xxxxxxxxxxxxxx> <f4527be0812230010r62124fa7k4a51d73e942a4d28@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
On Tue, Dec 23, 2008 at 8:10 AM, Andrew Lyon <andrew.lyon@xxxxxxxxx> wrote:
> On Tue, Dec 23, 2008 at 5:20 AM, Todd Deshane <deshantm@xxxxxxxxx> wrote:
>> On Mon, Dec 22, 2008 at 2:37 PM, Andrew Lyon <andrew.lyon@xxxxxxxxx> wrote:
>>> Hi,
>>> I have a NEC USB2 PCIx card which I assign to a Vista HVM by adding
>>> pci = [ '0000:02:01.0', '0000:02:01.1', '0000:02:01.2' ] to the config
>>> file, the card works well in Vista but if I try to detach it, destroy
>>> the domain without shutting it down, or if the domain crashes, then
>>> the entire machine locks up, I have a serial console setup but it is
>>> completely unresponsive.
>>> Combined with the issue that when the machine is under heavy load
>>> Vista sometimes BSOD with "A clock interrupt was not received on a
>>> secondary processor" this causes the system to lockup frequently :(.
>>> I made sure to trigger safe removal of the device before detaching it.
>>> Perhaps all 3 functions of the card need to be detached at the same
>>> time? or am I wrong in assigning all 3 in the first place? they are
>>> all listed when I run xm pci-list-assignable-devices and it seems to
>>> be necessary to assign all 3.
>>> Assigning the device by adding the setting to the config file, or
>>> using xm pci-attach after the domain has booted does work, only
>>> detaching causes the lockup.
>>> This happens on my main workstation which is a Supermicro X7DWA-N
>>> running Xen 3.3.1 rc4 (also tried 3.3 with fix for "ValueError:
>>> unsupported format character ':' (0x3a) at index 6" and
>>> fix_find_parent.patch), I usually use my own Gentoo ebuild for Xen
>>> dom0 kernel which is with the openSUSE Xen patches rebased to
>>> apply to vanilla without any of the other patches that openSUSE kernel
>>> usually applies, but I have also tried using the interim 2.6.27 kernel
>>> from http://xenbits.xensource.com/ext/linux-2.6.27-xen.hg with the
>>> same result.
>>> I replicated the problem on a Dell Optiplex 755 using the same
>>> versions of Xen and kernel, but using a dlink network card which is
>>> assigned as a single function (0000:02:01.0), it behaved exactly the
>>> same, lockup on xm-detach.
>>> I seem to recall a commit recently for "hypervisor panic on domain
>>> destory with passthru", but I cannot find it, anybody know where i can
>>> find it and if it may help?
>> Maybe this is the one:
>> http://xen.markmail.org/search/?q=panic#query:panic
>> list%3Acom.xensource.lists.xen-devel+page:2+mid:tfphqwwdstovpq5u+state:results
>>> Thanks
>>> Andy
>>> Andy
>>> _______________________________________________
>>> Xen-users mailing list
>>> Xen-users@xxxxxxxxxxxxxxxxxxx
>>> http://lists.xensource.com/xen-users
>> --
>> Todd Deshane
>> http://todddeshane.net
>> http://runningxen.com
> That patch appears to already be merged into 3.3.1 rc4, it must be a
> different problem.
> Andy

I would really appreciate it if somebody could try xm pci-detach and
report if it works or if they get the same lockup problem that I've
had, I'd really like to get it working so that I can migrate hvm's
with passthru devices.

I also noticed another problem, I attached a Intel Pro 1000 PCI NIC to
a running Windows XP HVM, the nic was detected and drivers loaded but
in dom0 I got some messages about interrupts and the sata controller
appeared to die, is it possible that the irq for the pci nic and
onboard sata are shared? perhaps passthru should be disallowed in that
case if it causes problems?


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>