This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] HVM phy: disks not working; file: disks no problem

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] HVM phy: disks not working; file: disks no problem
From: "Mark Walkom" <markwalkom@xxxxxxxxx>
Date: Fri, 19 Dec 2008 15:46:53 +1100
Delivery-date: Thu, 18 Dec 2008 20:47:48 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:in-reply-to:mime-version:content-type:references; bh=EmA+t09R9Yr515stn0a7zHb5T591vWPXz0ngS76j95o=; b=wYeNAGVxfwThKyxd/fuXZIGwTa8rWCcZCCtEUYoqeluqveNPXPcYGK4HXeRWdqSAFX WyK6qvwcSKM/ZbPGTvgqSDdfM3PL0BKPxW5TqsOPmU1STAtK+/lW5fN034IoIqkPx6FV tYEU3C2HUVVTKZG30XlxHWbXod1hOUurSfv0U=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:in-reply-to:mime-version :content-type:references; b=utfvlRR4Y8OoXR+/VSvqtHprSUPrNl5ECGtzQSmxenP0RCPoFxqVg8jF6fpGD7tX/f wLndKJwc/xYz4tk0lhzRzhOXEO/EgE0Zk+4bRPxxH6h/rD89mQ5wVAejiA1vU+NLwcrV 1fP+r0CZjRoW15C2S6fCTa31sFKLNVVOPBdbQ=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <494B260C.7070300@xxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <494B260C.7070300@xxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
In my experience I've always used full paths to the LV, so;
  disk =  [ 'phy:/dev/domU/w2k30.root,hda,w' ]

It's worked for me.

2008/12/19 John Morris <jman@xxxxxxxxxxx>
CentOS 5.2 dom0 w/fairly recent updates on x86_64, xen 3.2.0 RPM from xensource recompiled for x86_64, Win 2k3 domU (with GPL PV drivers).

With HVM, phy: disks on LVs won't work, although the same host has many PV CentOS hosts running no problem from LVs.  The file: disks work with no problems.  The disk configurations I've tried:

Neither works:
  disk =  [ 'phy:domU/w2k30.root,ioemu:hda,w' ]
  disk =  [ 'phy:domU/w2k30.root,hda,w' ]

  Selected logs:
  [2008-12-19 12:00:11 3365] INFO (XendDomainInfo:1504) createDevice: vbd : \
      {'uuid': 'dada2695-5fdd-85c9-3990-8d1978a35782', 'bootable': 1, 'driver': 'ioemu', \
      'dev': 'ioemu:hda', 'uname': 'phy:domU/w2k30.root', 'mode': 'w'}
  [2008-12-19 12:00:12 3365] INFO (XendDomainInfo:1273) Domain has shutdown: name=w2k30 id=63 reason=poweroff.

  disk  =  [ 'file:/d/distro.w2k3/w2k30.root,hda,w', ]
  disk  =  [ 'tap:aio:/d/distro.w2k3/w2k30.root,hda,w' ]

  Selected logs:
  [2008-12-19 12:05:15 3365] INFO (XendDomainInfo:1504) createDevice: tap : \
      {'bootable': 1, 'uname': 'tap:aio:/d/distro.w2k3/w2k30.root', 'mode': 'w', 'dev': '\
      hda', 'uuid': 'ee5b79fa-2286-dcab-9864-21af8fce8a8e'}

With the phy: disk, the host will begin to boot, but then immediately shut down.  The phy: disk image was created by dding the file from the installed file: image into the blank phy: LV.

If booted from the win2k3 install CD (cdrom specified as file:, disk as phy:), the install hangs forever at "Setup is starting Windows", presumably as it's trying to grok the hard drive configuration.

I managed to get the domain to pause during the Plex86/Bocks Bios, and see the disk detection as follows:
  ata0 master: QEMU HARDDISK ATA-7 Hard-Disk (   0 MBytes)
  ata0  slave: Unknown device

  Booting from Hard Disk...

At this point the domain shuts down.

More information:

  [root@xen-3 distro.w2k3]# lvs /dev/domU/w2k30.root
    LV         VG   Attr   LSize Origin Snap%  Move Log Copy%  Convert
    w2k30.root domU -wi-a- 5.19G
  [root@xen-3 distro.w2k3]# fdisk -l /dev/domU/w2k30.root

  Disk /dev/domU/w2k30.root: 5570 MB, 5570035712 bytes
  255 heads, 63 sectors/track, 677 cylinders
  Units = cylinders of 16065 * 512 = 8225280 bytes

                 Device Boot      Start         End      Blocks   Id  System
  /dev/domU/w2k30.root1   *           1         660     5301418+   7  HPFS/NTFS

Complete config file follows.  Let me know what else I can provide to debug this problem.  Thanks-


# xen configfile for host w2k30.bt1.ablesky.com
# use 'xm create w2k30 mode=install' to boot from w2k3 install CD
name = "w2k30"
memory = 1024  # memory for normal operation
shadow_memory = 8
# disks
#disk =  [ 'phy:domU/w2k30.root,ioemu:hda,w', ]
#disk  =  [ 'file:/d/distro.w2k3/w2k30.root,hda,w', ]
disk  =  [ 'tap:aio:/d/distro.w2k3/w2k30.root,hda,w' ]
# network interfaces
vif = [ "mac=00:16:ee:a8:c8:26, type=ioemu, bridge=btbr, model=e100", ]
kernel = "/usr/lib64/xen/boot/hvmloader"
builder = "hvm"
device_model = "/usr/lib64/xen/bin/qemu-dm"
sdl = 0
vnc = 1
vnclisten = ""
vncdisplay = 1
vncconsole = 1
vncunused = 0
vncpasswd = ""
nographic = 0
stdvga = 0
serial = 'pty'
# test if mode variable is defined
except NameError:
  mode = 'normal'
if mode not in ('install','reinstall'):
      # this is for after install
      boot = 'c'
      on_reboot   = 'restart'
      on_crash    = 'restart'
      # these are for install
      disk = [ 'file:/d/distro.w2k3/en_win_srv_2003_r2_datacenter_with_sp2_vl_cd1.iso,hdb:cdrom,r', \
               'file:/d/distro.w2k3/en_win_srv_2003_r2_datacenter_with_sp2_vl_cd2.iso,hdc:cdrom,r' ] + \
      boot        = 'd'
      on_reboot   = 'destroy'
      on_crash    = 'destroy'

Xen-users mailing list

Xen-users mailing list