This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] Missing etho in paravirt domu

To: "'Antoine Benkemoun'" <antoine.benkemoun@xxxxxxxxx>
Subject: RE: [Xen-users] Missing etho in paravirt domu
From: "Venefax" <venefax@xxxxxxxxx>
Date: Fri, 12 Dec 2008 05:38:25 -0500
Cc: 'Andy Burns' <xen.lists@xxxxxxxxxxx>, 'Xen List' <Xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Fri, 12 Dec 2008 02:40:22 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:from:to:cc:references :in-reply-to:subject:date:message-id:mime-version:content-type :x-mailer:thread-index:content-language:x-cr-hashedpuzzle :x-cr-puzzleid; bh=1pV5iSuNRoVYRqtuPvJFSiwRc/7WK11+Ldq2ucxHD0Y=; b=YS0Tptr9uJ7AarMFCf6EJagroDOVx+JyrJqPGSycJym+vpBqKLHvpsyh1bld5tF6NR fLokeYmMS/+6hI8Iwiw72ANEA5d17KpOsHVbmlYQxCC+OkykRv/Icy+1QP5RDo+3efz9 WAChv3HVeCcWNxPyQz1BbAkn9si+F9aiqxxBE=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=from:to:cc:references:in-reply-to:subject:date:message-id :mime-version:content-type:x-mailer:thread-index:content-language :x-cr-hashedpuzzle:x-cr-puzzleid; b=GRIXbNapcSbWlMX24ckLws6tS4MDGu7V9EBQnnF7k0hVaV8kB9kk/oi5N9ghhC3H2S oX4TZ/cgT8r6dxYR1HHV3Qkwd5DVm//hAWWFZcjvn1o6CZqWiH6ZtY1a5ctz+1YFkWwd ZZmvEuDD6tTBKkm2p3l854I/vVpXTPyVI9idA=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <fc1cbedb0812120228i7c4ef46fqbcd55142ba730533@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <m3iqpr6ixo.fsf@xxxxxxxxxxxxxxxxxxx> <b4057d410812111534h5b127dd4v5581175eab233ff5@xxxxxxxxxxxxxx> <ed123fa30812112332r73ddf353x239e2631e5cb14ee@xxxxxxxxxxxxxx> <010c01c95c42$2d9c1350$88d439f0$@com> <fc1cbedb0812120228i7c4ef46fqbcd55142ba730533@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AclcRFkmjCC9/jcVSVu+pXEHPpHssQAAK6sw

I solved it.

The file /etc/modprobe.conf was  missing.

According to Red Hat, it needs to have two lines:

alias eth0 xennet

alias scsi_hostadapter xnblk



From: Antoine Benkemoun [mailto:antoine.benkemoun@xxxxxxxxx]
Sent: Friday, December 12, 2008 5:28 AM
To: Venefax
Cc: Andy Burns; Xen List
Subject: Re: [Xen-users] Missing etho in paravirt domu


Have you tried ifup eth0 ?

Antoine Benkemoun
Tel :
Port :


On Fri, Dec 12, 2008 at 11:12 AM, Venefax <venefax@xxxxxxxxx> wrote:

I am using SLES 10 SP2 and a Centos 5.2 64 paravirt domu. Please look at the boot sequence below and let me know what is wrong. I cannot use the network. How do I fix this? I have important data in the VM that I need to save.



Bootdata ok (command line is  )

Linux version 2.6.18-92.1.18.el5xen (mockbuild@xxxxxxxxxxxxxxxxxxxx) (gcc version 4.1.2 20071124 (Red                                                                                         Hat 4.1.2-42)) #1 SMP Wed Nov 12 09:48:10 EST 2008

BIOS-provided physical RAM map:

 Xen: 0000000000000000 - 0000000040800000 (usable)

No mptable found.

Built 1 zonelists.  Total pages: 264192

Kernel command line:

Initializing CPU#0

PID hash table entries: 4096 (order: 12, 32768 bytes)

Xen reported: 2925.864 MHz processor.

Console: colour dummy device 80x25

Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes)

Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes)

Software IO TLB disabled

Memory: 1013760k/1056768k available (2418k kernel code, 34204k reserved, 1349k data, 176k init)

Calibrating delay using timer specific routine.. 7322.19 BogoMIPS (lpj=14644394)

Security Framework v1.0.0 initialized

SELinux:  Initializing.

selinux_register_security:  Registering secondary module capability

Capability LSM initialized as secondary

Mount-cache hash table entries: 256

CPU: L1 I cache: 32K, L1 D cache: 32K

CPU: L2 cache: 4096K

CPU: Physical Processor ID: 4

CPU: Processor Core ID: 2

(SMP-)alternatives turned off

Brought up 1 CPUs

checking if image is initramfs... it is

Grant table initialized

NET: Registered protocol family 16

ACPI Exception (utmutex-0262): AE_BAD_PARAMETER, Thread 2B7A0 could not acquire Mutex [2] [20060707]

No dock devices found.

ACPI Exception (utmutex-0262): AE_BAD_PARAMETER, Thread 2B7A0 could not acquire Mutex [2] [20060707]

Initializing CPU#1


Brought up 2 CPUs

PCI: Fatal: No PCI config space access function found

PCI: setting up Xen PCI frontend stub

ACPI: Interpreter disabled.

Linux Plug and Play Support v0.97 (c) Adam Belay

pnp: PnP ACPI: disabled

xen_mem: Initialising balloon driver.

usbcore: registered new driver usbfs

usbcore: registered new driver hub

PCI: System does not support PCI

PCI: System does not support PCI

NetLabel: Initializing

NetLabel:  domain hash size = 128

NetLabel:  protocols = UNLABELED CIPSOv4

NetLabel:  unlabeled traffic allowed by default

NET: Registered protocol family 2

IP route cache hash table entries: 65536 (order: 7, 524288 bytes)

TCP established hash table entries: 262144 (order: 10, 4194304 bytes)

TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)

TCP: Hash tables configured (established 262144 bind 65536)

TCP reno registered

audit: initializing netlink socket (disabled)

audit(1229076397.880:1): initialized

VFS: Disk quotas dquot_6.5.1

Dquot-cache hash table entries: 512 (order 0, 4096 bytes)

Initializing Cryptographic API

ksign: Installing public key data

Loading keyring

- Added public key DBA16EE6DC31700

- User ID: CentOS (Kernel Module GPG key)

io scheduler noop registered

io scheduler anticipatory registered

io scheduler deadline registered

io scheduler cfq registered (default)

pci_hotplug: PCI Hot Plug PCI Core version: 0.5

rtc: IRQ 8 is not free.

Non-volatile memory driver v1.2

Linux agpgart interface v0.101 (c) Dave Jones

RAMDISK driver initialized: 16 RAM disks of 16384K size 4096 blocksize

Xen virtual console successfully installed as xvc0

Event-channel device installed.

Console: switching to colour frame buffer device 100x37

input: Xen Virtual Keyboard/Mouse as /class/input/input0

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2

ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx

ide-floppy driver 0.99.newide

usbcore: registered new driver hiddev

usbcore: registered new driver usbhid

drivers/usb/input/hid-core.c: v2.6:USB HID core driver

PNP: No PS/2 controller found. Probing ports directly.

i8042.c: No controller found.

mice: PS/2 mouse device common for all mice

md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27

md: bitmap version 4.39

TCP bic registered

Initializing IPsec netlink socket

NET: Registered protocol family 1

NET: Registered protocol family 17

XENBUS: Device with no driver: device/vbd/51712

XENBUS: Device with no driver: device/vbd/51728

XENBUS: Device with no driver: device/vif/0

XENBUS: Device with no driver: device/console/0

Write protecting the kernel read-only data: 461k

USB Universal Host Controller Interface driver v3.0

Registering block device major 202

 xvda: xvda1 xvda2

 xvdb: unknown partition table

device-mapper: uevent: version 1.0.3

device-mapper: ioctl: 4.11.5-ioctl (2007-12-12) initialised: dm-devel@xxxxxxxxxx

EXT3-fs: INFO: recovery required on readonly filesystem.

EXT3-fs: write access will be enabled during recovery.

kjournald starting.  Commit interval 5 seconds

EXT3-fs: recovery complete.

EXT3-fs: mounted filesystem with ordered data mode.

SELinux:  Disabled at runtime.

audit(1229076401.944:2): selinux=0 auid=4294967295 ses=4294967295


CentOS release 5.2 (Final)

Kernel 2.6.18-92.1.18.el5xen on an x86_64


host-2centos52-1 login: root


Last login: Fri Dec 12 04:38:30 on xvc0

[root@host-2centos52-1 ~]# ifconfig

lo        Link encap:Local Loopback

          inet addr:  Mask:

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:132 errors:0 dropped:0 overruns:0 frame:0

          TX packets:132 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:9614 (9.3 KiB)  TX bytes:9614 (9.3 KiB)


[root@host-2centos52-1 ~]# ifconfig eth0

eth0: error fetching interface information: Device not found

[root@host-2centos52-1 ~]#

Xen-users mailing list


Xen-users mailing list