This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] HVM problem with Athlon cpu

To: xen list <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] HVM problem with Athlon cpu
From: helicoterus-elih@xxxxxxxx
Date: Tue, 9 Dec 2008 13:41:59 +0000 (GMT)
Delivery-date: Tue, 09 Dec 2008 05:42:34 -0800
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.it; h=X-YMail-OSG:Received:X-Mailer:Date:From:Reply-To:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding:Message-ID; b=DdczQioEzvKX8MwWN5R4OqE0a51t+xUcnfwJyeQbuIOFgPcAJu8O6DpuKFvwGQmHMtc2qN9RbvOt8Ero+17IxJXeVcRU+EWlRFb8o2nbG4liP6HwhzGzQGWMrsnsrVMYEPs8TyGwUcnlcdUasBCl316U/h/ZYKYh+gs5NG/YiGM=;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Reply-to: helicoterus-elih@xxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I own an Athlon 64 X2 Dual Core Processor 5200+. I enabled SVM extensions on 
BIOS. I did a power cycle.

xm dmesg shows me:
(XEN) AMD SVM: ASIDs enabled
(XEN) HVM: SVM enabled
I run a 64 bit Xen kernel (OpenSuse 11). Xen version is 3.2.1_16881_04-8.6

I _can not_ run any x86_64 O.S on a HVM domU, because it appears something like 
this: "your cpu does not support long mode. use a 32bit distribution.."
Using 32 bit distros, it works but I would like to use 64 bit O.Ses.

This is the output of xm info | grep caps command:
hw_caps : 178bf3ff:ebd3fbff:00000000:00000010:00002001:0000000:0000011f
xen_caps : xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32 hvm-3.0-x86_32p

Can some one help me? I think it can be a Xen bug, because I tried it
with Ubuntu Hardy Heron 64 bit and I get the same error.


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>