This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Unable to find number for device (sda2)

To: "Arpan Jindal" <jindalarpan@xxxxxxxxx>
Subject: Re: [Xen-users] Unable to find number for device (sda2)
From: "Siddharth Wagh" <siddharth.wagh@xxxxxxxxx>
Date: Mon, 8 Dec 2008 12:25:21 -0500
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 08 Dec 2008 09:26:01 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:cc:in-reply-to:mime-version:content-type:references; bh=o8KErBnMSbPsaXSpzFa3a1PAiHEYPuv96JI1QBSkYpM=; b=VjjGLZJ1+L+9wCQ4w6Ut/v+qDnkvR5FO78aIuMI6EbxQA1NhpGDgUF4deOOt+BIbB7 ijG75UvaMjPqKi4scjsnabG8cdw1c9LISVIPr0ixXIr0I/hMNNAWqeJoswE5jVRE296j FeRU9QwayAKhINVzu2DECMVKoQ+On041NX1Z8=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:cc:in-reply-to:mime-version :content-type:references; b=aq5gKQgOTjVoPJyUX74NrN8f6OinBTFSMpuP2klKF+pg1qb5NaERd7DXub39NO+RSc dnWa6ZQLereGSpqd2vCbNoP2I4tf2gzEwybm1GMSryK7u747YJPc8w3IbQ4+Kz1DXgTp Eye3/K9eimBAyXpWVELPJmq8LUunbFKvgryaM=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <b2d4ab9d0812080919x45b95602x227e4f83fd24fe6e@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <ad4b80f30812080806y69167c68of9f78d15ad2a58c7@xxxxxxxxxxxxxx> <b2d4ab9d0812080905h44ff945cw6d73a58570df87eb@xxxxxxxxxxxxxx> <ad4b80f30812080915x4764449k310d44a56266cef3@xxxxxxxxxxxxxx> <b2d4ab9d0812080919x45b95602x227e4f83fd24fe6e@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
It worked! Can I know the reasoning behind it?
But there's another error now:
Cannot open root device "VolGroup00/logVol00"
Please append...
Kernel Panic - not syncing

i am not sure how to set the root parameter as well. Any hints?

Siddharth Wagh

On Mon, Dec 8, 2008 at 12:19 PM, Arpan Jindal <jindalarpan@xxxxxxxxx> wrote:
try in single quotes 

disk = [ 'phy:/dev/sda2,ioemu:hda,w' ]

On Mon, Dec 8, 2008 at 10:45 PM, Siddharth Wagh <siddharth.wagh@xxxxxxxxx> wrote:
Doesnt work. Same error.
sda1 (Linux) and sda2 (Linux LVM) are existing partitions
I am working on Fedora 8


On Mon, Dec 8, 2008 at 12:05 PM, Arpan Jindal <jindalarpan@xxxxxxxxx> wrote:
change the parameter as 

disk = [ "phy:/dev/sda2, sda, w" ]


disk = [ "phy:/dev/sda2, hda, w" ]

it will start working 

On Mon, Dec 8, 2008 at 9:36 PM, Siddharth Wagh <siddharth.wagh@xxxxxxxxx> wrote:
I am setting the disk parameters as:
disk = [ "phy:/dev/sda2, sda2, w" ]
in the config file

and getting the following error:
Unable to find number for device (sda2)

What could be causing the problem?
If I use "ls -l sda2" in /dev, I get the major and minor device numbers as 8, 1

Please enlighten.

Siddharth Wagh

Xen-users mailing list

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>