This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] DomU can't be destroyed

To: tad1214 <tad1214@xxxxxxx>
Subject: Re: [Xen-users] DomU can't be destroyed
From: Ken Cobler <kcobler@xxxxxxxxxxxxxx>
Date: Thu, 04 Dec 2008 17:47:49 -0600
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 04 Dec 2008 15:48:40 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20843670.post@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <20841610.post@xxxxxxxxxxxxxxx> <1228422631.24215.3.camel@ubu32> <20843670.post@xxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20081105)
tad1214 wrote:
Thomas Halinka-5 wrote:
Hi Tom,

I have searched for a bit and haven't found anything. I am having an
with DomU's persisting (even after a reboot) that aren't running, and
be destroyed. Problem is I cant create one with the same name either.
is Xen 3.3.0 on Centos 5.2.
[root@COBRA1 ~]# xm list.........
xm destroy leaves the xm still in xm list.

[root@COBRA1 ~]# xm create /etc/xen/auto/andy.centos.dev
Using config file "/etc/xen/auto/andy.centos.dev".
Error: VM name 'andy.centos.dev' already exists
this domain is managed through xenstore....

  # xm start andy.centos.dev

"man xm" does not show this option, but "xm" does
start Start a Xend managed domain ...

The rest of these are set up the same and work perfect. I'm sure its
something I'm missing on my part though.



Xen-users mailing list

Thanks for the quick reply Thomas,

I did the following.

[root@COBRA1 ~]# xm start andy.centos.dev
Xend has probably crashed!  Invalid or missing HTTP status code.

and ssh is now dead :-\. All the DomU's are still up though.....

The XM andy.centos.dev did not start.

Thank god for remote reboot strips :)

Any logs in particular I should post? I am fairly new to Xen.


I had the same problem when I compiled Xen 3.3. I was getting "domain not halted" when I tried to delete a domain that was halted.

I resolved the problem by commenting out the lines 1064-1067 in /usr/lib64/python/xen/xend/XendDomain.py

Then, when I run "xm delete domainXXX" it deleted the domain. I could then execute "xm new domainXXX" to make a new domain with the same old domain name.

Ken Cobler

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>