This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Moving domU's from SLES10SP1 (xen-3.0.4) ---->> SLESL10SP2 (

To: Xen List <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Moving domU's from SLES10SP1 (xen-3.0.4) ---->> SLESL10SP2 (xen-3.2.0)
From: James Pifer <jep@xxxxxxxxxxxxxxxx>
Date: Wed, 03 Dec 2008 10:35:36 -0500
Delivery-date: Wed, 03 Dec 2008 07:38:17 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Mailscanner-null-check: 1228924132.89443@SalFnmIDTpgvsgP7mw/vJQ
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I have several xen servers running on SLES10SP1, xen-3.0.4_13138-0.40. I
want to update them to SLES10SP2 hoping that will fix a few issues I'm
having. I also want to use an ocfs2 file system so I an use migrate,
etc, between my xen host servers.

So I built a new xen server using SLES10SP2, xen-3.2.0_16718_14-0.4. I
also setup an ocfs2 file system on our SAN. Everything seems good. My
problems started when I tried to move over my current domUs. 

First I tried a sles10 domU. I copied the sparse image file and config
file. Modified the config file to point to the new path for the image
file now located on the ocfs2 mounted file system. I then used xm create
to create and start the domU. It got created and started fine, but it
never finishes booting. 

Next I tried one of my Windows HVM. Same thing, it seemed to create
fine, but will not finish booting. It just sits at the Windows Server
2003 screen with the bar scrolling across the screen. 

How do I troubleshoot this?

More importantly, how do I move from existing domU's from xen-3.0.4 to


Xen-users mailing list