This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] iSCSi on Xen

To: "bart brooks" <bart_brooks@xxxxxxxxxxx>, <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] iSCSi on Xen
From: "Ian Pratt" <m+Ian.Pratt@xxxxxxxxxxxx>
Date: Sat, 31 Dec 2005 21:38:15 -0000
Cc: ian.pratt@xxxxxxxxxxxx
Delivery-date: Sat, 31 Dec 2005 21:43:19 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcYOSszjLgSrMYB3Rqybvx4y9mtRVgABgEFw
Thread-topic: [Xen-users] iSCSi on Xen
 > Has anyone been successful in installing and running iSCSI in
> If so, I would like to know your configuration -
> I'm running xen 3.0 (kernel 2.6.12) and have tried 
> linux-iscsi 4.x & 5.x, open iscsi and unh-iscsi. Most have 
> some compile issues, once resolved they will stack dump when 
> doing some iSCSI operations

I used to use linux-iscsi 4.x on xen -unstable just fine, but I haven't
tried in quite a while. [Some earlier versions did make various dubious
assumptions that weren't true on xen.]

One option would be to try the xen merge tree which is currently based
off the 2.6.15-rc6, and hence includes the open iscsi patches.


I haven't tried this, but would be interested to hear whether it works,
and would like  to fix it if it doesn't. 


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>