This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] cant get X on domainU

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] cant get X on domainU
From: slava@xxxxxxxxxxxx
Date: Wed, 28 Dec 2005 01:05:25 -0800
Delivery-date: Fri, 30 Dec 2005 15:34:40 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Internet Messaging Program (IMP) 3.2.4
I can't seem to be able to get X working on domain U
My setup
domain0 -ubuntu breezy
domainU -ubuntu breezy

I tried 3 techniques

1. ssh -X domainU
steps: on domain U
$ export DISPLAY=:0
$ xhost +
xhost:  unable to open display ":0"
on domain0  ssh -X domainU
result: ssh conection established no X forwarding starts.
after login tried startx, but get message user not authorized to start x

2. vnc
installed vncserver on domainU,
$ vncserver

New 'X' desktop is playbox-breezy-01-U:1
Starting applications specified in /etc/X11/Xsession
Log file is /home/slava/.vnc/playbox-breezy-01-U:1.log

$ cat .vnc/playbox-breezy-01-U\:1.log

27/12/05 19:22:49 Copyright (C) 2002-2003 RealVNC Ltd.
27/12/05 19:22:49 Copyright (C) 1994-2000 AT&T Laboratories Cambridge.
27/12/05 19:22:49 All Rights Reserved.
27/12/05 19:22:49 See http://www.realvnc.com for information on VNC
27/12/05 19:22:49 Desktop name 'X' (playbox-breezy-01-U:1)
27/12/05 19:22:49 Protocol version supported 3.3
27/12/05 19:22:49 Listening for VNC connections on TCP port 5901

on domain 0 tried to connect with gnome terminal server client using vnc
but connection gets refused

3 freenx
install freenx on domainU, nxclient on domain0, added user, setup
password. when try to connect i cant get past authentication completed
message. here is the log
NX> 203 NXSSH running with pid: 18470
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-45-SVN OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 login
NX> 101 User: slava
NX> 102 Password:
NX> 103 Welcome to: playbox-breezy-01-U user: slava
NX> 105 listsession --user="slava" --status="suspended,running"
--geometry="1152x864x24+render" --type="unix-gnome"
NX> 127 Sessions list of user 'slava' for reconnect:

Display Type             Session ID                       Options  Depth
Screen         Status      Session Name
------- ---------------- -------------------------------- -------- -----
-------------- ----------- ------------------------------

NX> 148 Server capacity: not reached for user: slava
NX> 105 startsession --session="playbox-breezy-01-U" --type="unix-gnome"
--cache="8M" --images="32M" --cookie="******" --link="lan"
--kbtype="pc102/us" --nodelay="1" --encryption="1"
--backingstore="when_requested" --geometry="1152x813" --media="0"
--agent_server="" --agent_user="" agent_password="******""

Killed by signal 15.

somebody please help :)

here is more info, not sure if helpfull
after boot on domain U this is end of my /var/log/syslog
Dec 27 19:14:54 localhost gdm[2022]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Dec 27 19:14:58 localhost gdm[2228]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Dec 27 19:14:58 localhost gdm[1971]: deal_with_x_crashes: Running the
XKeepsCrashing script
Dec 27 19:14:58 localhost gdm[1971]: Failed to start X server several
times in a short time period; disabling display :0

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>