This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Problem while booting dom0 in FC4 for Xen-2.0

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Problem while booting dom0 in FC4 for Xen-2.0
From: Steven Anderson <hikenboot@xxxxxxxxx>
Date: Fri, 30 Dec 2005 07:13:38 -0800 (PST)
Delivery-date: Fri, 30 Dec 2005 15:18:12 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:Received:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=eKgrIXMT+fEUz+3JPHiRJex201s/qvBH5ZWTbKV09lT73j2E1aXW5fLNfDMCn5Ckznv9OvihZC5XXHXIWlCq4ioB9WIGNrHuHEwkiCtLi7HRnMGBCpN86uZ/EALWGF4dY2s7uP8Dzo2Vk09rVCD4mtiUGUDQs0OCXgdpCtALuE8= ;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

I am looking at your config and notice that your kernel and xen are not located in /boot directory also you are using over 512mb ram for dom0...I have never used ovver 512 and wonder if there might be a limit..just a thought?

I run 3.0 version of xen this is your config:
title Xen 2.0 / XenLinux 2.6
kernel /xen-2.0.7.gz dom0_mem=720000
module /vmlinuz- root=/dev/sda3 ro console=tty0

Here is my working config:

title Fedora Core (
root (hd0,0)
kernel /boot/xen.gz dom0_mem=256000
module /boot/vmlinuz- ro root=LABEL=/ rhgb
module /boot/initrd-

notice i am running from boot directory (you get a message about it expecting it in boot)

Also i am running an initrd image never tried it without one but i understand its possible..just somthing to think about.

Thats the best i can do to help you out with my limited knowledge. Good luck and let me know if one of these suggestions fixes your problems!


Steven Anderson
Happy New Year!

Yahoo! for Good - Make a difference this year.
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Problem while booting dom0 in FC4 for Xen-2.0, Steven Anderson <=