This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] URGEND!!! Problems Bonding

To: DIEDERIT@xxxxxxxxxxxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] URGEND!!! Problems Bonding
From: Peter.Weiss@xxxxxxxxx
Date: Thu, 29 Dec 2005 16:16:15 +0100
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 29 Dec 2005 15:20:38 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <D883B61937A3FA45A4D8BAEA489AC7D104C43923@xxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/21.4 (gnu/linux)
On Dec 29 2005 DIEDERIT@xxxxxxxxxxxxxxxxxxxxxxxxxxxx wrote:

> [...]
> I installed Xen 3 on my machine. I copy the .config and did a make ARCH=xen
> oldconfig Then a make ande an ./install.sh
> My machine is booting, but my bonding device is not known..
> Can u help me?
> [...]

I've tried to setup bonding in Dom0 without success.  I think Xen-3.0 is not
really bonding aware at the current state of development. Here's what Greg
Brackley <greg.brackley-sender-8aba35@xxxxxxxxxxxxxxxxxxxx> said on Xen-devel
on this topic:

I believe it is possible to use bonding with Xen.  I have one machine
running successfully with 802.3ad bonding.

I have had a few problems with the networking, but I have overcome
most of them.  I was trying to use the bonding support in conjunction
with VLAN support. I still have concerns that there are some
outstanding issues with checksum offload support in the Xen network

To get the xenU networking operating I found I needed to disable
checksum offload support (ethtool -k eth0 tx off).  There doesn't
appear to be any such ethtool support in the xen0 loopback driver.  I
also dug around a little in the kernel code to look at the checksum
offload options[1][2], and was unclear as to why a loopback style
device like the xen loopback driver was declaring that it was capable
of TCP/UDP IPv4 checksum offload.  It might explain why I could get
ICMP working but not UDP/TCP (Note sure how/if this relates to similar
IPsec issues).  I would be very keen to get clarification on this

I think there might also be some interaction with the NIC driver. My
tg3 based machine works 'out of the box', whereas the e1000 solution
requires the checksum offload disabled in the Xen driver. I was also
using a non-GPL sk98lin based sk-9e22 card which was having problems,
but I plan to use the newer sky2 driver when I get time.

You didn't mention what problems you were having? Whether it worked
without xen, etc. What does /proc/net/bonding/* say?

I have been disabling the xen network script (and not doing the
interface renaming etc), and using the FC4 init scripts to bring up my
xen0 networking. I needed to tweak the xen0 hotplug. Other than the
problems discussed above I have managed to get the networking going.
I would like to resolve the checksim offload, but have had time to
look into it.


I also failed to setup bonding on the XenU. First it looked quite optimistic,
the /proc/net/bonding/bond0 file looked correct, but the traffic was still
routed over only one interface.

Hth -- Peter

Peter.Weiss@xxxxxxxxx                         ConSol* Software GmbH
Phone  +49 89 45841-100                       Consulting & Solutions
Mobile +49 177 6040121                        Franziskanerstr. 38
http://www.consol.de                          D-81669 München

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>