This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen 3 with PAE and more than 4GB of memory on X86 32bit

To: Ian Pratt <m+Ian.Pratt@xxxxxxxxxxxx>
Subject: Re: [Xen-users] Xen 3 with PAE and more than 4GB of memory on X86 32bit
From: Andrew Turnbull <abturnbull@xxxxxxxxx>
Date: Mon, 19 Dec 2005 08:17:09 +0000
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 19 Dec 2005 08:19:49 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=eVfl6zQ6ENJms2Zu3SdpM6UlvVnjf7O12Thz7Yk9KAKdmAr5AWh04iCrflAG+cuhqgm343WAwjM+Dvqbqak8cI0c1bVlL7Zc4UXlicD5X8th8hKEqbvBtH+KWBbYJvec5zoHGiTTT4cJmUuTA/pRpxMA5Bd5Zf3g6G32RfN1zXM=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <A95E2296287EAD4EB592B5DEEFCE0E9D409DC6@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <A95E2296287EAD4EB592B5DEEFCE0E9D409DC6@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

I think I found the answer, I wasnt setting the memory in both Xen0
and XenU to 64GB.

Xen0 was 64G and XenU was 4GB.


On 19/12/05, Ian Pratt <m+Ian.Pratt@xxxxxxxxxxxx> wrote:
> > This is a general question has anyone got Xen 3 to work with
> > more than 4GIG of memory installed on there physical machine?
> >
> > I have tried 2 different machines with more than 4 GIG of
> > memory with no success as yet.
> >
> > I can get Xen0 booting no problem, i run service xend start
> > with no problem, i then run xm info and it sees more than 4
> > gig of memory available. Fantastic up to this point.
> >
> > After creating my xenU config script. I then run into problems.
> >
> > However when I try to do an xm create xen01 (for instance) it
> > comes up with invalid argument error 22 and then the second
> > time its error 14, then 22 then 14 and so.
> We use PAE on up to 16GB systems all the time. Try using xen-bugtool to
> create a report.
> Thanks,
> Ian

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>