This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] some beginnerkernel questions

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] some beginnerkernel questions
From: Sanjay Upadhyay <glowfriend@xxxxxxxxx>
Date: Sat, 17 Dec 2005 15:01:41 +0530
Delivery-date: Sat, 17 Dec 2005 09:34:01 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=b0SxjSxQFUlHBZQi8dxEnvjw4cJ9KY5VG7RMqJJPXWgktxvvf3cWh9lIeh609X1f+ZJTKVeJ1ekWRIBsoqRJTX3r8W6+LHxXf4I2efNXobtKGyU9vpNslHCUlPZs8qx69nng4j0QAyxER+1IHcr1iphdvqwJM2q0enGu9Td7PnM=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <FIEPLFEPPCJLKBACLHOIGELCCMAA.md@xxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <FIEPLFEPPCJLKBACLHOIGELCCMAA.md@xxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
You may not need to recompile the kernel, however a very good link is
here http://www.howtoforge.com/perfect_xen_setup_debian_ubuntu

Another point, either referring a initrd image in the grub does cause
a problem, try to remove that from there. Hope that would correct the
I have the following given under the /boot/grub/menu.1st..

title Xen 3.0.0
    kernel /boot/xen-2.0.gz dom0_mem=25600 console=vga
    module /boot/vmlinuz-2.6-xen0 root=/dev/hdb1 ro console=tty0

I had a entry like this (which i removed and the problem was solved)
    module /boot/initrd.img

On 12/17/05, md <md@xxxxxxxxxxxxx> wrote:
> Hi List,
> I run XEN 2 since some month (unfortunatly installed by a fiend of mine).
> Recently I bought some new hardware and tried to get XEN 3 running on a
> Debian Sarge 3.1.
> I installed via the Debian installer a RAID 1 with LVM. even though there
> are some devfs_mk_dir errors systems comes up.
> Now I installed XEN but system doe not boot as the boot device seems not to
> be recocnized by the kernel. I found the message already dealt with in some
> threads...
> Root-NFS: No NFS server available, giving up.
> VFS: Unable to mount root fs via NFS, trying floopy.
> VFS: Insert root floopy and press ENTER
> So I nw know that I have to recompile the XEN kernel according to my system.
> Two questions:
> I never kompiled a kernel before - so is there maybe a way to keep my Debian
> confirguration that is working and just add this to the XEN stuff?
> Regarding the devfs_mk-dir issue I found the solution to upgrade to kernel
> 2.6.13 or above. Is it corrct tat XEN 3 is still using 2.6.12 and as I have
> to recompile the kernel in any case - how can I do this with the latest
> stable version
> Any help woudl be appreciated
> Mathias
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>